CUDA Installation error : Extraction Failed

I’ve been trying to install CUDA 8.0.44 on CentOS 7.3.

Firstly, I downloaded Runfile using following command:
$ wget https://developer.nvidia.com/compute/cuda/8.0/prod/local_installers/cuda_8.0.44_linux-run

After, I made sure that Nouveau driver was disabled and typed following command.
$ sudo sh cuda_8.0.44_linux-run

Then something went wrong. The shell is saying: Extraction failed. Ensure there is enough space in /tmp and that the installation package is not corrupt.

If you know how to deal with this problem, could you please give me some advice? Thank you.

you should be installing 8.0.61, not 8.0.44

maybe you don’t have enough space in /tmp

some modern linux distros use a special /tmp directory setup, and this can be problematic if you have small system memory size (e.g. 1GB).

To test/workaround this, specify a different temp directory. The installer has a switch for this.

Use

sudo sh cuda_8.0.44_linux-run --help

to get a list of switches available. One of them will allow you to specify an alternate temp dir.

Thank you for your response. And I’ll apologise about my bad English sentences.

According to your advice, I made a new directory on home directory and tried
$ sudo sh cuda_8.0.44_linux-run --tmpdir=./temp
but the alternative directory seems to have only 1.1GB .

Is it possible to expand the size of a directory?

a directory in your home space shouldn’t have arbitrary limits.

Perhaps you are running out of space in your home space?

Perhaps you are running out of space on the disk?

I am experiencing the same error, even after changing temp dir.
Configuration:
Ubuntu 16.04.3 LTS (Xenial Xerus)"
Linux version 3.10.0-514.6.1.el7.x86_64
gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) )

i had the same prblm , then i discover that the size of the folder downloaded not completed for example it should be 1.5GB but i found it 500MB (reason of the internet connection) so it gave this error ,just re download the file and verify the size so prblm solved .I hope it will help