Unable to install CUDA SDK

I recently installed the CUDA driver and toolkit and wrote my first CUDA programs, which turned out fine.

However, if I try to install the SDK I always get the following error message

Extraction failed.

Signal caught, cleaning up

I tried SDK 2.3 and 3.0-beta but both exit with the same error message.

I use Ubuntu 9.10 64-bit and have a GeForce 280GTX.

That “Extraction failed” message comes from a call to tar. The installer itself is incredibly basic, it (more or less) just runs tar to extract an archive which is attached to the installer. It probably means that you either don’t have enough free disk space wherever you are running the installation, or you don’t have write permissions to wherever you are doing the installation.

That cannot be it as I have the same problem and: 1) have 200Gb of free space and 2) I am extracting it into my home folder. I can extract and install the toolkit 3.1 release though BUT I can’t extract the SDK as I get the same error. I am using(as I said in the thread I opened) Debian Squeeze.

Quick Fix:

Run the installer as root, and append -target ./nvidia to the end