CUDA with "GeForce GTX 1070 Ti"?

I’ve tried installing (clean, packaged and run file, Centos 7) multiple times without success. Can someone confirm CUDA is not compatible with the GeForce GTX 1070 Ti model?

I wanted to add to this: it is listed on this site: “https://www.geforce.com/hardware/technology/cuda/supported-gpus” but not the site listed in the guide: “https://developer.nvidia.com/cuda-gpus”.

CUDA (in some version) is supported by all GeForce, Quadro, Tesla, and Titan GPUs that have been produced since 2007. The latest CUDA versions (9, 9.1 at this time) support all GPUs from the Kepler generation forward, including your GTX 1070 Ti (a Pascal generation GPU).

The website where it is not listed is not perfectly maintained. However the above statements cover all such questions.

The CUDA linux install guide details the proper procedure for installation. For the newest GPUs, you may need to install a driver separately from the CUDA toolkit installer. The installer (run file) may not contain the latest driver needed for your GPU.

  1. Install the latest driver for your GPU. Get your driver from http://www.nvidia.com/drivers
  2. Install the CUDA toolkit of your choice using the runfile installer. Get your runfile installer here: http://www.nvidia.com/getcuda Follow the instructions in the linux install guide
    https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

During installation of the CUDA toolkit runfile installer, answer “no” when prompted to install the GPU driver that is bundled. The latest driver from step 1 will work with any CUDA toolkit.

Cheers, many thanks for this. I’ve been over many install permutations (run file no separate driver install, package install with separate driver install, etc) but not this one. This provides some much needed confidence. Thanks again.

Hello @rasmussj
Do you have any news for us if it worked?
Thank you in advance.

I did it now myself and can guarantee it works with the 1070 Ti
Greetings

This was helpful - thanks.