Cyberpunk 2077 1.62 , 1.63 crashes

Hello , There seems to be a problem with the game , and the linux drivers.
The game crashes since 1.62 , patch where CDPR installed their new eye candy techs , and the game started breaking from this moment on linux. Until now , it is still unplayable as it freezes and crashes usually between 5 to 30 minutes.
right now , it just crashed , I had to manually kill it , and ran dmesg which gave me :

[ 2466.946421] NVRM: GPU at PCI:0000:01:00: GPU-4d7d7644-3303-be1c-3a53-d139ef3b1b4c
[ 2466.946427] NVRM: Xid (PCI:0000:01:00): 31, pid=8479, name=GameThread, Ch 0000011f, intr 00000000. MMU Fault: ENGINE GRAPHICS GPCCLIENT_GCC faulted @ 0x6330_00000000. Fault is of type FAULT_PDE ACCESS_TYPE_VIRT_READ

there is a github issue about it here :

Also , I noticed that this crashing problem and it’s symptoms is extremely frequent for people who have an RTX 20xx .
You can see on protondb for cyberpunk , that pretty much everyone who has this bug has an RTX 20xx , myself included , I have a 2060 .
This problem doesn’t exist on other games , and didn’t occur in earlier versions of cyberpunk like 1.61

Is there any known fix ?

Yes. Exactly same behavior.
I have 2060s. but crash sometime occurs ±1s after loading game.
also i have 1.61 on my drive that don’t crashes so it was introduced with path-tracing.

1 Like

Also , here are the logs from the debug script , I didn’t this tool existed :
nvidia-bug-report.log.gz (40.2 MB)

We have seen similar issues with other games as well and is currently being tracked via bug 3959156.
Team is currently debugging the issue.


Hello, do we have any updates about bug 3959156 ? :)

sadly nothing … it’s been months having this problem

Any updates on this issue? Been experiencing crashes with the latest drivers (535.104.05).

Bump. Still having the same issue in Cyberpunk patch 2.0, RTX 2060 Super, driver 535.113.01, ProtonGE8-16.

1 Like

Lucky AMD cards owners…

Adding that I am also experiencing the same issue. Happens almost immediately after game starts even with most the updated Proton from Steam.

[1434597.044342] NVRM: Xid (PCI:0000:07:00): 31, pid=753054, name=GameThread, Ch 00000051, intr 00000000. MMU Fault: ENGINE GRAPHICS GPCCLIENT_GCC faulted @ 0x2460_00000000. Fault is of type FAULT_PDE ACCESS_TYPE_VIRT_READ
[1435517.080830] NVRM: Xid (PCI:0000:07:00): 31, pid=755143, name=GameThread, Ch 00000051, intr 00000000. MMU Fault: ENGINE GRAPHICS GPCCLIENT_GCC faulted @ 0x26d0_00000000. Fault is of type FAULT_PDE ACCESS_TYPE_VIRT_READ
[1437499.954052] NVRM: Xid (PCI:0000:07:00): 31, pid=758951, name=GameThread, Ch 00000051, intr 00000000. MMU Fault: ENGINE GRAPHICS GPCCLIENT_GCC faulted @ 0xfffff5e0_00000000. Fault is of type FAULT_PDE ACCESS_TYPE_VIRT_READ

Also using --launcher-skip -dx12 as game Launch Options

Linux Mint
CPU: AMD Ryzen 5 5600X 6-Core @ 12x 3.7GHz
RAM: 16648MiB / 31993MiB

Do we have an idea of what’s happening? I am willing to try anything to get this bug resolved.

edit: added bug report
edit 2: extremely recent bug report
nvidia-bug-report.log.gz (985.5 KB)

I’m experiencing the same issue as described here on my 2070 Super. Cyberpunk will inevitability lock up and need to be hard killed within minutes of starting a new game.

It would be great if we could get an update from nVidia, given it’s been 2 months since the last update on this issue.

[13603.415275] NVRM: Xid (PCI:0000:01:00): 31, pid=13960, name=GameThread, Ch 000000de, intr 00000000. MMU Fault: ENGINE GRAPHICS GPCCLIENT_GCC faulted @ 0x56a0_00000000. Fault is of type
[13990.913645] NVRM: Xid (PCI:0000:01:00): 31, pid=14956, name=GameThread, Ch 000000e9, intr 00000000. MMU Fault: ENGINE GRAPHICS GPCCLIENT_GCC faulted @ 0x39a0_00000000. Fault is of type

OS: Manjaro
CPU: AMD Ryzen 7 7700X
Memory: 31240MiB
Driver Version: 535.104.05

Can you please attach a bug report by following this below step?

“Please also generate and post an “nvidia bug report” by running as root.”

After generating the report I also had to sudo chown [user] nvidia-bug-report.log.gz to read the file. But this would help the devs with solving the issue.


Sure, I can add the bug report. However, I’d prefer to put the bug report somewhere else as it includes my username information which I’d prefer not to provide. I can do a find/replace if needed.

[Edit] Free now to get the bug report. Attached.
nvidia-bug-report.log.gz (454.8 KB)

@amrits, for what it’s worth and in case you haven’t noticed them yourself already, there are a few reports in the Proton issue tracker that could perhaps be helpful with the debugging:

  • reverting to 510.108.03 might be solving the Xid 31 crashes
  • a hypothesis was put forward that the problem might be related to DLSS (as 510.108.03 doesn’t support it)
  • for some people at least the crash is 100% reproducible when receiving “phone calls” in Cyberpunk
  • other people have mentioned that while they don’t get crashes (but using 535.104.05, not 510.108.03), the same in-game “calls” tank their performance really hard for inexplicable reason

Here are the relevant posts:

Thank you very much for your hard work on this and the other issues with the driver.


Hi, yes, I’m one of the submitters of observations in the proton github issue. The game crashes very very reliably for me in the opening scenes of the “corpo” start, if I’m using the 525 driver. By using the 510 driver, I managed to complete the entire first act with no glitches or anything else - it was rock solid stability.

I have an RTX2080 (not super), and I’m running debian sid for the most part.

Also to note, the phone call elements weren’t slow or glitchy for me during the 510 version play through - they were fine and worked as expected. I would say that I didn’t experience any specific slowdown or glitches - Ultra settings (such as can be set on Linux) were absolutely stable.

The 510 kernel driver experience is NOT easily palatable otherwise however - I’m currently on a 6.0 kernel, as it’s the latest that seems to be able to compile the proprietary driver. Newer kernels hit missing symbol errors. I’m looking to see if I can find a way patch the problem, but there’s not a lot of patches for the 510 kernel I can find, it seems like it was pretty transitory.

1 Like

before you spend hours wasting your time recompiling previous drivers :
Did you test the stability of the game AFTER a save ?
Be careful , this bug is extremely sneaky … I launched a new game , and could play for 3 hours straight without a crash … But after loading a save , it started crashing after 5 min as it did for the last 5 months.

I’ll add my 2 cents on this issue.
I’m getting the same Xid crash/freeze which semi hangs your PC and you need to kill the game manually:

Sep 28 17:59:31 arch kernel: NVRM: Xid (PCI:0000:06:00): 31, pid=22958, name=GameThread, Ch 0000009e, intr 00000000. MMU Fault: ENGINE GRAPHICS GPCCLIENT_GCC faulted @ 0xffff9ba0_00000000. Fault is of type FAULT_PDE ACCESS_TY>
Sep 28 17:59:31 arch kernel: NVRM: GPU at PCI:0000:06:00: GPU-deee3779-d1c5-f87a-57bd-d32a0cfa687a

I can’t reproduce this crash at all: sometimes its 1 minute of gameplay sometimes its 1hour, but i never managed to get a session going over 1hour 30 minutes without a crash. Switching to 6.1.55-1-lts kernel seemed to make the quick 1 minute crashes disappear, but just today I tried playing on the 6.5.5-zen1-1-zen and managed to get a 50 minute session while on a previous zen kernel I was getting very quick 1 minute crashes. The crashes are very random: sometimes it happens when driving, sometimes in a dialogue cut scene, sometimes just standing around doing nothing. The people mentioning getting the crash consistently when they get a phone call - I never had a crash when receiving a phone call myself.
At this point I’m just very confused and all the proton switches, launch options don’t seem to do anything, besides the kernel switch seemingly making the crashes less frequent.

DLSS off and switched to FidelityFX which may or may not help, I recall this helping but it might just be random coincidence.
Proton version: GE-Proton8-16
Launch options: gamemoderun mangohud %command% --launcher-skip -dx12
OS: Arch Linux x86_64
Kernel: 6.5.5-zen1-1-zen
CPU: AMD Ryzen 5 3600
GPU: NVIDIA GeForce RTX 2060
GPU Driver: NVIDIA 535.113.01
Memory: 31.25GiB
DE: Plasma 5.27.8 with xorg
nvidia-bug-report.log.gz (1.9 MB)

I was playing from the same save that was taken moments into the corpo start (before you leave the bathroom).

It would crash every single time just standing in the bathroom or lobby area after a couple of moments (the phone call from the “boss” seemed to be the trigger of the crash).

Driver version 510, this never happened, I could play on without issue. I just also opened my steamdeck 1.6 save on the PC, and it loaded fine and I was able to play for a bit. Looks like I’ll be doing the DLC LOL.

I take what I can at this point , if I can have most of the time an hour without crashing , that’s far better than anything I tried in the last 5 months

I am just done with Nvidia. i can play for like 20mins max. and then it crashes.
I am stupid that i havent bought AMD when i had a chance. then i wouldn’t have any Xid errors because AMD community fixes games faster than nvidia.