Debugger started to ignore breakpoints

Hello, as the title clearly says,

I’ve encountered a problem with the Nsight debugger. The GPU debugger (Legacy mode only supported for my Nvidia Geforce 930m) simply ignores all my breakpoints.

It might be just a stupid mistake on my side but I can’t seem to find the solution.

Using Windows 10 64 bit, Nvidia 930 m, driver 419.67, Visual Studio 2017.

Before I was able to successfully debug. Debug is not working on new projects inside my solution, I have also tried old projects inside that solution and debugger ignores breakpoints in there too, before it worked though.

Maybe it has something to do with the fact that I have installed this new driver a few days ago (I cant really say whether the debugging broke Immediately after the update or not). I dont know what driver I was using before.

Do you have any idea of what could be wrong? I would be grateful for any help.

Thank you, have a nice day.

I don’t think there are any known driver related issues with the Legacy Debugger.

  • Are you using NsightVSE 2019.1?
  • You can get the recommended drivers from the same page (I don't know that 419.67 is the problem, though)
  • Maybe the code wasn't compiled with symbolics? If you can't hit source breakpoints in your __global__ or __device__ kernel functions, you would still be able to set/hit function breakpoints on the same functions. Ctrl+B (in VS2017), then enter .* for the function name to set all function breakpoints If this works, ensure you are using nvcc with the -G switch to generate debug information (symbolics) for GPU/device code
  • Are your source and binaries in sync?
    • Are breakpoints showing up on other lines of code? This is a sign that the breakpoints are jumping to valid lines of code (ie. from a comment line)
    • Can you set an SASS/PTX breakpoint and have it hit on the expected line

The first point already did it… Thank you very much.

I am not sure why it’s stopped working before but now I can finally keep working.

It would be interesting to know what version of NsightVSE you were using before.
I guess it is possible that there was some incompatibility between the old NsightVSE and the new driver.

I am not sure I can find out.

If it is of any help, I was using the stock Visual Studio 2017 and the stock nvidia cuda toolkit, without any other customizations whatsoever.