DeepSpeech for Jetson Nano

Hello Nvidia Devtalk community,

For those who are interested in running DeepSpeech on the Jetson Nano (yes, it does) - i have build Tensorflow 1.13.1 and DeepSpeech 0.5.1 with CUDA support for the Jetson Nano.

Any feedback on this is welcome.

Best regards,

Will have to try this out, thanks for sharing!

It would also be great if you could re-post this to the Jetson Projects forum so it’s archived there, in addition to any examples of running it you have.

I have succesfully built DeepSpeech 0.6.0 for Jetson Nano:

Thanks for the sharing!

Does this work on the Jetson Nano? I’m getting Internal: Dst tensor is not initialized which indicates that the GPU runs out of memory.

1 Like

I have my Nano running in headless mode with approx. 3.5GB free RAM after boot. With that my (few) tests on Nano worked without the error you are seeing.

1 Like

I only got that error the first time I tried to transcribe an audio file. When I ran DeepSpeech again, it worked. When attempting to transcribe an audio file that was not from the demo audio files, I found I needed to have Sound eXchange (SoX) installed which can be done by running the command:

sudo apt-get install sox

deepspeech --version is showing blanks for the TensorFlow and DeepSpeech versions.

1 Like

Just noticed that I have missed to announce following builds:

DeepSpeech v0.8.2 for Jetson/Xavier
DeepSpeech v0.9.0a10 for Jetson/Xavier

Both builds were successfully tested on Xavier AGX (JetPack 4.4/LT32.4.3) and Xavier NX (JetPack 4.4 DP/LT32.4.2), but should work on any Jetson TX1/TX2/Nano and Xavier AGX/NX with JetPack 4.4 (CUDA 10.2, TensorRT 7.1, cuDNN 8.0)

Just yesterday DeepSpeech 0.9.0 was released by Mozilla.
Here is my build: DeepSpeech v0.9.0 for Jetson/Xavier