Delphi ESR 2.5 with sample_radar_replay

When I try to use the sample_radar_replay file live with my DELPHI_ESR2_5 radar sensor, it does not connect. I have it connected via CAN_E and nothing else. Can someone walk me through how to set it up so that it can run correctly?

Dear vdonikia,

Did you check Radar Point Clouds Sample section in DW doc?
Please help to check DriveWorks SDK Reference -> Samples -> Other Sensor Samples -> Radar Point Clouds Sample

Yes I have been trying to follow the reference but it is not working. I am inputting exactly how the documentation says to enter the information however I am not able to get the point cloud to even show up. I get an error the IP and port could not be connected to.

Hi, I am having the same issue, the point cloud does not show up.

I try to ran sample_radar_replay with the following config: “./sample_radar_replay --protocol=radar.socket --params=device=DELPHI_ESR2_5,ip=169.254.145.71,port=5555”, the gl window opens, but it says the packets:0 and no radar detection or tracks are shown. Is there another config, I need to make ?

When I connect delphi esr 2.5 24 volt to Nvidia DRIVE PX2, I can ping it and see some is recieved when I ran ifconfig from command prompt. When I connect this radar to DataView by CANbus, I can see the detected objects.
My SDK version is 5.0.10.3.

Dear elif.toy,

There’s generally additional configuration one need to do over CAN for the device to switch over to IP.
Could you please let me know if this was done? Thanks.