Running ./sample_record or ./sample_radar_replay with custom radar and decoder

We are trying to run either of these samples with a custom radar and decoder. We are encountering the same errors with both.

Is this a bug or are we just specifying the protocol incorrectly?

Following are the commands we have tried and associated errors:

./sample_radar_replay --protocol=radar.socket --params=ip=177.2.2.1,port=21234,device=CUSTOM,decoder=/home/nvidia/dw_moving/libradardecoder.so

nvrm_gpu: Bug 200215060 workaround enabled.
Initialize DriveWorks SDK v0.6.67
Release build with GNU 4.9.2 from v0.6.0-rc7-0-g51bd3aa against Vibrante PDK v5.0.5.0
TimeSource: monotonic epoch time offset is 1528404189531845
TimeSource: PTP ioctl returned error. Synchronized time will not be available.
TimeSource: Could not detect valid PTP time source at 'eth0'. Fallback to CLOCK_MONOTONIC.
SDK: Resources mounted from ../data/resources
SDK: Create NvMediaDevice
SDK: use EGL display as provided
SDK: number of GPU devices detected 2
SDK: currently selected GPU device discrete ID 0
SAL: identified board as DrivePX2-TegraA
SensorFactory::createSensor() -> radar.socket, ip=177.2.2.1,port=21234,device=CUSTOM,decoder=/home/nvidia/dw_moving/libradardecoder.so
RadarSocket: expected protocol parameter missing
Driveworks exception thrown: DW_INVALID_ARGUMENT: protocol parameter
./sample_radar_replay --protocol=radar.socket --params=ip=177.2.2.1,port=21234,device=CUSTOM,protocol=radar.socket,decoder=/home/nvidia/dw_moving/libradardecoder.so

nvrm_gpu: Bug 200215060 workaround enabled.
Initialize DriveWorks SDK v0.6.67
Release build with GNU 4.9.2 from v0.6.0-rc7-0-g51bd3aa against Vibrante PDK v5.0.5.0
TimeSource: monotonic epoch time offset is 1528404189531845
TimeSource: PTP ioctl returned error. Synchronized time will not be available.
TimeSource: Could not detect valid PTP time source at 'eth0'. Fallback to CLOCK_MONOTONIC.
SDK: Resources mounted from ../data/resources
SDK: Create NvMediaDevice
SDK: use EGL display as provided
SDK: number of GPU devices detected 2
SDK: currently selected GPU device discrete ID 0
SAL: identified board as DrivePX2-TegraA
SensorFactory::createSensor() -> radar.socket, ip=177.2.2.1,port=21234,device=CUSTOM,protocol=radar.socket,decoder=/home/nvidia/dw_moving/libradardecoder.so
Driveworks exception thrown: DW_INVALID_ARGUMENT: protocol parameter

terminate called after throwing an instance of 'std::runtime_error'
  what():  Sensor Initialization Failed
Aborted (core dumped)

Dear jgs2185,

The radar replay sample just support CONTINENTAL_ARS430 and DELPHI_ESR2_5.
Please see /usr/local/driveWorks0.6\nvdwx_html\dwx_radar_replay_sample.html in DPX2 or HostPC.

Running the Sample
The command line for the sample to display live radar point clouds is:
./sample_radar_replay --ip=[radar IP address] --port=[lidar port] --device=[type of device]

Where [type of device] is one of the following:
•CONTINENTAL_ARS430
•DELPHI_ESR2_5

For Radar sensor decoder plugins, please refer to “Integrating with Custom Sensors” part in DriveWorks Develpment Guide. Thanks.

Then is it also not possible to run a custom radar and decoder with sample_record?

Are there any samples that can accept data from a custom radar?

If not, is there a suggested procedure for testing a custom decoder in the DriveWorks framework?

Dear jgs2185,

Could you please refer to “Integrating with Custom Sensors” part(Page 17) in DriveWorks Develpment Guide?
and in DriveWorks SDK Reference, please see DriveWorks API -> Sensors -> Radar Thanks.