Desktop Resizing is Broken on 460.39

The same underscan correction values have always worked for me through each driver revision. After upgrading from 455.45.01-1 to 460.39-1, no matter what underscan values I use, the desktop is drawn in such a way that it is barely usable, as the panel and applications are drawn beyond the usable desktop area. Reverting to the previously installed version fixed the issue.

I’ll try to describe this further, although I feel like I don’t know enough about how drivers handle desktop transformation to adequately or accurately describe it. As expected, before any underscan or resizing, with the default resolution of 1920x1080, it’s overscanned such that I can’t see the boundaries of the desktop. However, I can use the panel (eg: select the icon of a running application) by orienting the mouse beyond the visible area. Yet as soon as any significant underscan compensation is applied (~+10), the panel is no longer usable, as it is rendered beyond the usable, pannable desktop. The same issue occurs with applications as well.

When using my previous go-to settings that have always worked (in: 1920x1080, out:1824x1026+48+27 panning: 1920x1080, force composition pipeline), the boundaries of the desktop space itself are correct (ie: I cannot pan beyond them, and there are no black bars). Yet, again, the panel is rendered beyond the usable desktop, and I cannot access it. Fullscreen applications cannot be fully viewed, because the window rendering extends beyond the desktop space.

Nothing has changed from a hardware standpoint, nor have the “rules” of resizing changed (for lack of a better term); Using my Extron DVS 605A set at 1824x1026+48+27, it still takes the 1920x1080 resolution and perfectly resizes it (albeit, as always, it introduces motion artifacts), while the Nvidia 460.39-1 driver makes a mess of it. Relevant specs: Arch Linux, kernel linux 5.10.16.arch1-1, XFCE with XFWM. The driver with the underscan issue is nvidia-dkms 460.39-1. Hardware: Panasonic plasma tv (TCP42X3), X58 non-EFI compatible motherboard, 30GB DDR3, GTX 1060 6GB.

I’m surprised to see that no one else has mentioned this issue. To be frank, I’m a bit disappointed with Nvidia, as one would think that desktop resizing is a basic feature that is tested for functionality before pushing out incremental driver revisions.

Unfortunately I did not do further troubleshooting, and prefer to avoid the driver that’s not working for me; as my system doubles as a server and workstation, I must be careful to prevent breakage and avoid downtime, plus this seems like something that should be easily reproducible. I did notice no errors in the journal, nor anything atypical in the xorg log.