Device not found after every reboot

I installed 2.3 and 2.3 drivers, toolkits and SDKs in different times. Both of them didn’t work after the first reboot.

Actually, I can work with them with no problem after installing but reboot makes something weird…

I get There is no device supporting CUDA. error when I run deviceQuery.

Is there anybody having the same problem, and can you suggest me solutions please?

I have 9400M on a new MBP. I have Leopard installed.

Hi there,

I think I posted a similar message few days back.

Installing earlier version of CUDA packages did not help.

However, I installed the set of 2.3a packages and it seems the problem is now gone :-)

My earlier optimism about 2.3a is faltering. The loss of a CUDA kext on reboot is happening to me now under 2.3a. Both CUDA and OpenCL examples compiled and run, mostly, but this is now annoying me. Can someone remind me of the permanent fix, as I cannot find it now!

The fix that worked for me I posted over here:

No CUDA device after rebooting