deviceQuery causes panic without sudo - R32.2 Custom debootstrap rootfs

I am building a minimal rootfs with R32.2 TX1/Nano drivers using debootstrap. The intent is to create a minimal Nano OS to run CUDA applications with static libs. When deviceQuery is run with sudo it completes without errors, however running as a standard user causes a kernel panic and reboot. If I run deviceQuery as a standard user after running it with sudo, it has no issue completing. I suspect this is a permissions issue, however I can not seem to track it down.

  • Standard User is a member of the “video” group
  • Output from kernel panic is minimal and does not seem to point me in the direction of solving the issue.
  • All /dev/nvhost device ownership is root:video with the exception of nvhost-dbg-gpu and nvhost-prof-gpu which show root:root
  • Installing the full sdks with SDKM / JP 4.2.1 has the same result.

hello blokeandsally,

since you’re able to reproduce the same issue with JetPack-4.2.1.
could you please share the commands and also the failure message for reference.

Issue is solved with the installation of wayland/weston. Only root is able to access the GPU without these packages. I am now trying to sort out a minimal way to solve this, without the need to carry 300MB+ of additional packages. Any advice would be appreciated (assuming I am on the right path).