Display port over USB-C with docking station - only one display works even two displays are recognized

@amrits I’m sorry, but I can’t provide you any info because they gave me a docking station with DISPLAY LINK !!! Argghh!! So I can’t compare apples to apples - because my current setup is:

  1. Legion 5 with ryzen 5800h, rtx3060
  2. docking station i-tec catriple4kdockpd CATRIPLE4KDOCKPD | i-tec USB 3.0 / USB-C / Thunderbolt 3, 3x 4K Docking Station + Power Delivery 85W | i-tec
  3. Two Dells as in the first post.

Due to the fact that I was given this crappy docking station which uses display link the displays are not even visible in Fedora 34 (because DisplayLink requires separate drivers). So fail. I installed Ubuntu 20.04.
Under Ubuntu (20.04 after instanlling has 470.52.02 nvidia drivers and the displaylink drivers), the displays are recognized and you can see the wallpaper, but when I try to reorganize the displays (you know set the one on left to be on right and change e.g. refresh rate) after clicking Apply in Gnome-Settings, it just hangs and hard reset is needed.

I’m waiting for a docking station without this display link stuff and I ordered a usb-c to DP cable adapter as well (maybe connection without the docking station but through HDMI and that cable will suffice somehow).

Aaa - very important thing.
It works in Windows by default (no action on my side needed). Those guys there working on Windows are just darn lucky!

I will try to provide more info when I receive the docking station - maybe somebody in the meantime can help?

Resume from Suspend (ACPI S3 mode to be precise) doesn’t work. Anyone experienced this as well?

To be precise the laptop resumes, but the screen is blank - like turned off.

Wow, the resume after suspend (from ACPI S3) works when the dedicated mode is off - even though the Nvidia driver is loaded. That’s strange - because when I switch to dedicated mode in BIOS, it doesn’t work (the display is like turned off even though the computer is running)

Hi gietki,
Regarding original issue initiated in this thread, we are not able to duplicate issue so far.
Tried on below configuration setup a day ago but no luck.

Thinkpad Thunderbolt Dock Gen2 + Lenovo Thinkpad P15 + Ubuntu 20.04 + 2 x 4K monitors - Samsung LS28AG700N.

@amrits yo man!

Unfortunately I cannot reproduce fully the initial situation that was described in this thread, because I have a different laptop now and different docking station.


My current setup is:

  1. Lenovo Legion 5 with RTX3060,
  2. Two dell displays (same as the inital)
  3. NO DOCKING station - because the one with DisplayLink just doesn’t work in all of the distros I tested (Fedora34, Ubuntu 20.04, Ubuntu 21.04).

But having HDMI and USB-C with DP ports, I connected the two displays over those ports(one HDMI cable and one USB-C to DP converter “Silver Monekey” is the brand name) and it works BEAUTIFULLY under Ubuntu 21.04 (kernel #33 Ubuntu SMP).
Driver version is : 470.57.02 (installed via Ubuntu software updater)

I tried the above setup with Fedora 34 and Ubuntu 20.04 but it doesn’t work (I don’t know why, haven’t had time to analyze it).

I’m aiming to connect the displays via a docking station (but a one without DisplayLInk technology - the one which was described in the initial message in this thread) but I’m waiting for the delivery from Czech Republic.

The one thing that just bothers me for now (apart from not having the docking station to test) is that when I go into UEFI and change the Graphic Card mode from “Dynamic” (which is probably how Lenovo calls Optimus technology) to “Discrete” - which is only having RTX to work (not the AMD Renoir GPU) the resume action doesn’t work - because the screen in laptop doesn’t turn on (but the external display does - so that’s strange).

All in all I can see that there’s a progress because I tried similar setup (hdmi + usb-c to DP converter) with previous drivers and all the distros mentioned (Fedora34, ubutnu) with newer/older kernels at that time and it did not work properly. (You can see the picture from 29th May in this thread above)

Here’s a picture for all you lads who are still fighting the issue (and btw. when I open the lid of the legion laptop it works as well just with a third screen):

@amrits so yea, thank you!

Hi gietki,
Thanks for the feedback.
I tested with suspend-resume cycles as well but I have no repro.
I also switched to Fedora 34 to match the kernel and GNOME versions without repro.
Please share newer bug report with 470 drivers.

Hi @amrits

Thanks for the feedback. Unfortunately I cannot switch over to Fedora 34 (i’d need to format the disk) or anything else at the moment, because this is my production set (I work on it). So I will stick to the Ubuntu (instead of Fedora) for now.

There are two issues though:

  1. First thing missing here is that I cannot make it resume from suspend when I’m in “discrete mode”. It only works when both GPUs are turned on in the UEFI.
  2. The other factor is that I’m still waiting for the i-tec docking station (the one without the DisplayLink technology). (it is still on its journey from Czech Republic).

When I receive the docking station I will let you know if it works.

BTW. can you please share what setup have you got? (because Lenovo Thinkpad P15 has many configurations, I assume you have Intel CPU). I’m amazed that it works for you under Fedora 34 out of the box.


Hi @amrits
Bad news. The docking station won’t be available until 15th of September. All I can do for now is to provide bug report log from the resume from suspend in “dedicated mode”. I see that there are several topics in this forum about it as well.


sure, that will really help us.

Please share bug report log from the resume from suspend in “dedicated mode”.
Also let us know if you were able to receive docking station and tried for repro with latest driver release ?

hi @amrits,

  1. Sorry I totally forgot (just life). I will reproduce the resume from suspend today in the evening and share it.
  2. As for the docking station - it supposed to arrive two or three weeks ago, but it did not. The producer (i-tec) sends small number of devices to the shops - at least this is what they say (probably the semiconductor global situation is taking its toll? and the price in two months has risen over 20%) one of the shops wrote to me that they have a planned deliver on 15.10 (in almost 3 weeks!) and will reserve it for me. So waiting for it (I want to get rid of the all cables sticking out of the notebook - rj45, us, hdmi, usb dongles for mouse and keyboard etc.) so unfortunately I need to wait.

Hi @amrits

Apologies again and as promised I’m attaching the nvidia-bug-report. nvidia-bug-report.log.gz (452.3 KB)

So the report concerns the aforementioned resume from suspend bug (when having the dedicated mode turned on in the EFI). Please see the photo below - which presents the situation after resume - two displays are back online, but the notebook screen is off - it should be turned on (it was turned on before suspend - it is the “main screen” with the Ubuntu/GNOME main menu at the top and left side).
Reproducing is fairly easy:

  1. Just invoke Suspend action from the system menu.
  2. Wait for the notebook to go to sleep (to be precise ACPI S3 mode).
  3. Press any button/power to resume the notebook from suspend .
  4. Viola, you have the situation same as in the photo below.

The system is Ubuntu 21.04, kernel: 5.11.0-36-generic #40-Ubuntu SMP, nvidia drivers version: 470.57.02.
I have also previously installed evdi (display link crappy drivers - but I think that they are not used - I had to install them when I was testing one of the i-tec stations which ultimately I returned and now waiting for the one without this technology).

I hope you’ll get something out of the logs and the community and myself will benefit from your findings. If you need more info don’t hesitate and once again thanks for reminding about this issue.

All the best,

hey @amrits

I’ll start by saying that the docking station arrived, I tried it and to be honest I give up (I’m returning it on Monday).

Nvidia bug report: nvidia-bug-report.log.gz (359.3 KB)

The docking station is: i-tec C31TRIPLEDOCKPD | i-tec USB-C/Thunderbolt 3 Triple Display Docking Station + Power Delivery 85W | i-tec

The displays as above connected via DP (both).

So I plugged in the station via USB-C with PD and at the beginning it even worked (well I thought so).


  1. After connecting the docking, I restarted the notebook and it was really sad experience, because the display where the Gnome login screen should appear was blank (nonetheless I was able to login because I remember the login sequence - muscle memory - so after logging in the third display which was blank turned on - see step 2). You can see it in the picture:

  1. After I entered my credentials I tried to set the refresh rate to 144Hz on every display. I was able to select it (the list with refresh rate allowed me to do it), but after clicking the apply button it went straight back to 60Hz. (PS. I tried here also swapping one DP for HDMI - same result)

In the picture you can see the refresh rate which I’m trying to set:

and after applying it went back to 60Hz (I tried to do it several times)

  1. So I thought "hmmm maybe I will swap cables in the docking station and restart - maybe the docking station allows only 144Hz at one display but not on the other), so I swapped the cables and go this result - the display went off.

  1. So I thought damn… let me try setting off the Optimus on UEFI - so I turned the discrete mode - restart included, and boom! Every screen was blank.

To be honest I give up with this docking stations (all of them - at least for several months, maybe a year, until someone fixes and stabilizes the drivers and I’m not talking about Nvidia only, but other drvs as well). I’m currently working via two cables connected to the notebook (one HDMI and one USB-C to DP converter) - and it works like a charm. The refresh rate is 144Hz each, no blank screens after resuming (apart the discrete mode with RTX only - described above). The resume from suspend remembers the screens (doesn’t swap left to right and vice versa).

I really tried on this. But it failed. What’s more - it works on Windows without any additional configuration (no blank screens, no problems with refresh rate, no swapping left to right after resume, no changing the display mode from “join displays” to "replicate) etc.

Maybe in a year time we’ll meet again. Thanks for your work on this.

I am facing a very similar problem, that the screen is not waking after sleep.
Thinkpad P1 Gen2 with Nvidia T2000
Thinkpad Thunderbolt 3 Docking Station
Thinkvision P27u via DP on Thunderbolt 3 Dock

While it does work with Open Source nouveau driver, it does not work with the all the Nvidia drivers I’ve tested so far (470.74).
See here, also with bug reports:

@fhortner not only you. In this forum there are plenty of threads concerning resume after sleep (going from ACPI S3 state back to online). They all have in common that the display is “off” (even thought the signal is on). I hope that they @amrits will figure this one out.

The worst part is that under Windows all works well (but who uses Windows nowadays apart from gamers? ;)) )

I saw these threads, but there is one difference:
1.) I am using a Thunderbolt Dock, like you
2.) The external monitor is not even recognized - so no signal at all

Recently I´ve updated my OS from Ubuntu Budgie 20.04 to 21.04, but since the NVidia driver 440 I have problems with my external 4K displays that I use through a Thunderbolt Workstation by Dell (WD19) connected to my notebook through a RTX2060.
My problems during the last year was distortion in image from external displays, like the 2nd photo in the begining of this thread, I have installed 450 and 460 driver version, with this problem, but now with 470 my both external displays are not working, the xrand recognize the displays but there is no image on those.
So I´ve returned to 450 drive version then the displays back to show image.

Displays Dell 4K 27¨
Workstation Dell WD19 Thunderbolt 3
GraphicCard RTX 2060 Thunderbolt Output

Looks like I am able to duplicate issue on below configuration setup -

Dell Precision 7560 + Ubuntu 20.04.2 LTS + T1200 Laptop GPU + Driver 470.74 + dock model Dell K17A + 2 displays connected via dock

I chose discrete graphics option from BIOS setup and powered on the notebook.
When I connected 2 external displays, all 3 displays are getting detected with xrandr -q but display appears on only one of the external monitor and notebook respectively.
Other remaining external monitor remains blank.

Ok, that’s great. Let the debug game begin :)