DLS IP Resets Itself

I installed a DLS-1 v1.1 Appliance on ESXi-1 and set it up using tokens.
It has an IP of and is registered in DNS.

The DLS-1 was ready to serve the licenses.
However, v2.0 was released.
So I created a new v2.0 VM called DLS-1-v2 and set it to a new IP as I wanted to use the original after the v2 VM was configured…

I did the migration of data from DLS-1 to DLS-1-v2 via migration file accessing the NVIDIA portal, etc.

The upgrade worked as on on DLS-1-v2 I can see 2.0.0 listed under the Maintenance page and also the license info.

I turned off the DLS-1 VM.

So, now i wanted to reset the IP of on DLS-1-v2 back to

Under the Service Instance page, I selected “CONFIGURE IP ADDRESS”
I went though the process of setting back the IP to
I got a confirmation the IP change worked and it would be available. in a few minutes.

In vCenter, i can see DLS-1-v2 took on the original and i can login vie chrome to

However, when i rebooted DLS-1-v2, the Ip reverted back to the temp IP of
I even tried resetting the IP from the console as dls_system and the it does not work.

Any ideas on why the IP is reverting back to the temp IP I used for DLS-1-v2


I had the same problem but found the solution: License System User Guide (nvidia.com)