DOA - Jetson Nano 2GB - Developer Kit

Hi All,

I think, I received (again) a DOA (Dead on Arrival) Jetson Nano 2GB - Developer kit.

jetson nano 2 gb developer kit with wireless usb adapter
model : P3531

When plugging in :
5.1v 3.0a official raspberry pi power usb-c connector, the green light turns on, but no signal (test1) on hdmi connected dell monitor1, (test2) on another hdmi connceted dell monitor2, (test3) hdmi connected samsung TV.

Tried with a apple 5v 2.1a power socket, (different usb-c cable on above monitors… (test4, test5, test6) again no output.

Then tried both power adapters, with no hdmi connected.
to see if my usb optical mouse, would give signal. Tested on all usb ports, no optical light. Did the same for my DELL keyboard, to see if capslock/numlock light would give any signal. No lights there…

(Not sure, but is checking lights on usb mouse/keyboard a good test?)

Also will the Jetson Nano maybe make a “beep” after bios check?

Important, this is the SECOND jetson nano 2 GB - developer kit I have received, the FIRST one, had exact same issues and was send back, for which I have received this one.

So am the I only one? or do I need to adjust a jumper? I’m missing something?

Otherwise, I need to send it back as DOA again. :( but find it very strange that I received a double DOA.

ps : The above mentioned poweradapters are working fine with other periphals.
ps : no SD card was attached.

other questions, with the earlier send DOA jetson nano 2 GB, will nvidia do any research, what the cause was of the DOA? and if it was a real DOA? I’m just curious.

The first thing to clarify is whether this is a hardware problem or software problem.

If your board can boot up but stuck in some boot sequence, then it can be resolved by software.

However, if even the board not able to boot, then we will consider as DOA.

Thus, to clarify which case is it, generally we connect a usb ttl cable on uart pin to dump the serial console. There should be some boot up log from it if the board is not broken.

Thank you @WayneWWW for your reply.

I dont have such a cable. Before I’m going to order one, I was wondering if the power to keyboard / optical mouse would give an indication of a DOA ? (optical light enabled - for example on the mouse.)

I don’t think using optical light on mouse would be sufficient to tell it.

There are few stages in boot sequence. Not every bootloader in each stage is able to initiate the usb. The later one will have more capability than previous one. For example, the last boot stage is linux kernel, which should initiate the usb.
Thus, if your boot stuck in some early stage when usb is not yet able to run, then it will not have optical light. However, under such case, our sdkmanager tool should be still able to re-flash the board and make it alive again.

Thanks @WayneWWW

Then I’m going to send this one as RMA. (again)

As you said, if it is software - the sdkmanager can reflash the DOA board. Still strange that a board is out of the factory, without proper flashing the bootloader. But lets see, thanks

Maybe you can try with sdkmanager first before doing RMA. It is a tool for end user, many users here are using this tool instead of sd image.

If you need some guidance, then I can help.

hi @WayneWWW

I requested for RMA. I’ll suggest the Nvidia support team to do a analysis with the sdkmanager.
(I dont have that usb to ttt serial cable in my possesion.)
They can then analyze whats going wrong. If I receive that info, I’ll post it in this topic. :)

edit :
What I havent checked / done, is the check the utp port if the light would go on on network level.
Though I would expect that this enablement, would be much later in the bootloader process. (then the initialization of USB)

edit2 :
Just checked, no lights on the Jetson Nano on the UTP network port, when connecting with a utp cable connected to my router.

Hello,

It is ok to do RMA too. Do you see the LED (green light) on the carrier board light up when you power up the board?

Hi @WayneWWW

Yes the green light is on, when connected to both power adapters in all situations:

this is the testing, I have done :

What testing did I do?

Connect it with official raspberry pi usb-c 5.1v 3.0a adapter.
Light on the Jetson Nano goes green.
Test.1 : no hdmi output using hdmi cable.1 on dell 27 inch monitor.
Test.2 : no hdmi output using hdmi cable.2 on another dell 27 inch monitor.
Test.3 : no hdmi output using xbox hdmi cable.3 on samsung TV,

Connect it with official apple 5v 2.1a adapter and another usb-c cable.
Light on the Jetson Nano goes green.
Test.4 : no hdmi output using hdmi cable.1 on dell 27 inch monitor.
Test.5 : no hdmi output using hdmi cable.2 on another dell 27 inch monitor.
Test.6 : no hdmi output using xbox hdmi cable.3 on samsung TV,

Connect it with official raspberry pi usb-c 5.1v 3.0a adapter.
Light on the Jetson Nano goes green.
Test.7 : connected optical mouse to all usb ports. (no optical light from mouse.)
Test.8 : connected keyboard to all usb ports. (no lights on keyboard, when pusing capslock / numlock / insert)

edit :
Test.9 - connected UTP network cable (connected one side to router) no, datalink yellow or green light to be seen.)


would there also be some more information about the bootloader / bios initialization?

for example :
power goes on (green light goes on?)
it detects a sd card?
it detects monitor output? and initializes?
it detects usb? and initializes?
etc etc

for future problem solving, might be good to have on this forum

To dump the log from bootloader, it requires to use usb-ttl cable and a host as I said in previous comment.

If this boot goes to cboot, then it will show boot logo.

Actually, I don’t think you should use those I/O to tell the status of the board.
Dumping the log is the most effective and efficient way for us to tell what is going on. Also, if the log tells us it could be resolved by software, then you still need to use sdkmanager to flash too.

Sdkmanager has some difference from sdcard image. We have some boot components on the jetson nano device QSPI hardware. If you only replace sdcard, it may not touch the components on QSPI. Thus, if those boot components are broken, then changing sdcard image is just trying the same thing again and again which will be in vain in the end.