Does CloudXR 2.1 work with that latest GRD 471.41?

No, the most recent driver supported by CloudXR 2.1 is 471.11. We suggest upgrading to CloudXR 3.0 which supports the latest drivers.