Does free version of omniverse run with AWS AMI and NiceDCV?

Currently using isaac-sim in AWS Nvidia Omniverse GPU Optimized AMI in headless mode and streaming via Omniverse streaming client, working out of the box. Thanks, it is solved by another post. Now trying with Omniverse Launcher. I tried with NiceDCV from AWS Nvidia Omniverse AMI, it fail to login to omniverse launcher, even though I could login to the remote machine. I followed the tutorial as this link : Virtual Workstation on AWS (Windows) — Omniverse Nucleus latest documentation

In NiceDCV when tried to login to my omniverse account with my email address, the launcher gave me this error.

http://localhost:33480/login-result?error_description=Authorization+flow+not+allowed&error=invalid_request

An error has occurred during the login:
[invalid_request] Authorization flow not allowed

I am using Nvidia Omniverse gpu optimized ami in aws and cloud formation has an option for niceDCV. Only thing is I am using g5 instances in Mumbai region, I am not using instances of USA. Can that be a reason?

Copilot/Bing told me as below.

The region of your AWS instances should not inherently cause the error you’re experiencing. The NVIDIA Omniverse GPU-Optimized AMI is designed to run on GPU-accelerated EC2 instances, including g5 instances1. However, there could be other factors at play.

Here are a few additional steps you can take:

  1. Check Your AWS Permissions: Make sure your AWS account has the necessary permissions to access the NVIDIA Omniverse GPU-Optimized AMI and to spin up g5 instances in the Mumbai region1.
  2. Verify Your AMI Version: Ensure you’re using the latest version of the NVIDIA Omniverse GPU-Optimized AMI1. If not, try updating to the latest version.
  3. Check Your Instance Configuration: Verify that your g5 instances are correctly configured to run the NVIDIA Omniverse GPU-Optimized AMI1.
  4. Contact NVIDIA Support: If you’re still experiencing issues, it may be helpful to reach out to NVIDIA support with the specific details of your setup. They may be able to provide more targeted assistance.

Two things:

  1. Launcher REQUIRES a GPU GUI. It cannot run headless
  2. " Authorization flow not allowed" ususually means you are running a version of Launcher that is too old to allow you to connect. Please go to www.nvidia.com/omniverse to download the latest launcher. It should be version 10 or 11
1 Like

Sorry for the delay reply, I was in a break for few days. Thanks for the response. I am talking about NVIDIA AMI available in AWS from NVIDIA. When I am opening the remote desktop via NiceDCV, the Omniverse Launcher is already there. It was pre-installed and I was not able to login to my Omniverse account. Launcher looked fine. So I assumed it is related to my account. Mainly it was kicking me out when I gave my email address. Please ignore the last part of my post , Bing part, it is “Bing rumbling”. Bing often misguide and divert the real issue.

Hello, having the same issue. Was this ever resolved? I’ve downloaded the latest launcher from omniverse and running on an AWS EC2 windows machine as instructed here: Virtual Workstation on AWS (Windows) — Omniverse Nucleus latest documentation

Any advice would be super appreciated!

1 Like

Well firstly if it was already logged in, use that. What account did they use ? Why can you not log out and log in as you ? There are so many questions. I would start with contacting AWS. We honestly are not invloved here. That is something you would need to contact them about.

1 Like

After I log in to NiceDCV, I see the desktop image, where I have Nvidia Omniverse Launcher icon. As usual I double click the launcher and it open Login interface of Omniverse Launcher. When I try to login with my credentials of Omniverse, it kicks me out from Omniverse Launcher. So in short, NiceDCV is not the problem. I could login perfectly fine. I am kicked out from Omniverse Launcher and I do not see any option to update the Launcher. Hope I could explain. I will send you screen shot, next time I try. Really busy with Isaac-Sim development. Isaac-sim is working with AWS and Omniverse Streaming Client. NiceDCV approach is different than Ubuntu docker container approach. Docker container approach is working perfect!

Right but again, why not contact your AWS rep or customer help ? We cannot support OV on AWS from here.

1 Like

You keep saying “it kicked me out”. What does that mean ? It literally CLOSED Launcher or it caused you to crash ? Or did it tell you, your creditials are wrong ? Can you login into Launcher on a simple local machine and make sure your creditials are correct ?

Why don’t you capture a video of this so we can see what you are asking. Even if it is on your iphone. Show me what is happening.

But again, talk to AWS Support. If they supply the hardware and the instance, then they need to troubleshoot. You may not need to actually log into launcher. The entire point of the AWS instance, is that they already have launcher ready to go. Just open it and start using it. If you login does not work, show me it not working.

1 Like

20240412_003615.zip (46.1 MB)

The zip file is a video, apology for the bad quality. OK, I will talk to AWS support. Please let me know, if this is related to login credential. I already have an Omniverse account with this credentials, and it is working in my local machine, but it does not allow me to proceed from NiceDCV instance. In video you will see, NiceDCV remote desktop opened and then I tried to login with my email address in omniverse Launcher. I followed this video tutorial
Omniverse Virtual Workstation on AWS | NVIDIA On-Demand

****Another possibility is, the g5 instances I am using from AWS do not have ports open.

Let’s see if we can get the Launcher Logs. It looks like your Launcher may be out of date. Something you should talk to AWS about.

Go to C:\Users\user.nvidia-omniverse\logs and send us the “launcher.txt” file please.

Please also try to install the new version directly over the old.

  1. close Launcher
  2. right click on the green launcher icon down in the bottom right hand corner of the system clock area and right click and go to Exit
  3. Run Task Manager. Go to details tab. Look for any threads starting with “omni”. Right click on each one and hit “end process”.
  4. Download the latest launcher https://install.launcher.omniverse.nvidia.com/installers/omniverse-launcher-win.exe
  5. Install it.
  6. Try again
1 Like