App (Create, Code) could not launch on AWS Windows machine

I am trying to run Omniverse launcher on Amazon AWS Windows machine (windows server 2019), using an omniverse-ready AMI (for example, NVIDIA Omniverse VDI Windows Image (for use with g4 and g5 instances) which is a community AMI).
No matter what combination of instance type (g4, g5) and driver type I use, the app install but would not launch. Some of the errors I see in the logs:

[omni.ext.plugin] Could not load the dynamic library from c:/users/administrator/appdata/local/ov/pkg/create-2022.3.1/extscache/omni.flowusd-104.1.9+104.1.wx64.r.cp37/bin/nvflowext.dll. Error: A dynamic link library (DLL) initialization routine failed.

[omni.ext.plugin] [ext: omni.warp-0.5.1] Failed to startup python extension.

[Error] [] HRESULT: 0x887a0005
[Error] [] CreateHeap failed.
[Error] [] Unable to allocate buffer

Any idea what combination of windows version + aws instance type + driver version will work?

Hello @itakatz! Unfortunately, I am not familiar with setting up an AWS machine. I will have to ask the dev team for some assistance.

Could you attached a copy of your logs for the application you are seeing this error occur? You can see where to grab your logs by reading this post: How to Report an issue with Omniverse

In the meantime, I was able to find some information in our documentation that may help.



Isaac Sim

Hi @WendyGram and thanks for your fast reply.
I read the docs about using Amazon AWS, but they are focused on using Ubuntu machines and NVIDIA dockers (which I tried and it worked). But the errors I reported above happen when I tried to use a Windows machine with the Omniverse Launcher. I guess the setup is not compatible in some way, so I’ll have to find another way.
Anyway, in case it helps, I attach 2 log files (one from Code app and one from Create app) with the errors I mentioned.
Some info about the setup: WIndows Server 2019 machine (I’ve tried a few AMI’s with NVIDIA GPU support, both Omniverse-specific and general), tried both T4 and A10G machines (AWS “g4dn” and “g5”), with a few driver versions - both the version builtin with the AMI image and the newest version. Also tried to roll-back to an earlier version. Nothing worked.
kit_20230105_132046.txt (952.7 KB)
kit_20230105_134534.txt (1010.8 KB)

Hi @Wendy I looked up the documentation the documentation of how to set up Nucleus on AWS but it seems extremely technical , I am wondering if there is any simpler solution (?).