DRIVE Development Platform Xavier | Pegasus, SDK Manager GUI doesn't show up in Host Linux PC

I installed SDKmanager in Ununtu 16.04 host PC, and want to flash it to Drive Xaiver system. But the Host Linux PC doesn’t display SDK manager when I launch SDK manager, see following:
I download and install sdkmanager_0.9.9-2351_amd64.deb in my Ubuntu 16.04 PC Server. and check the USB link to Drive Xavier debug USB port is good, and I also enable X11 at /etc/ssh/ssh_config files. but when I run sdkmanager, the sdkmanager small icon is displayed at left Ubuntu panel, but no big NVIDIA SDK MANAGER GUI show up.

sdkm.log (51.8 KB)
sdkmlog2.log (56 KB)
terminal.log (4.22 KB)
sdkm.log (64.4 KB)

Dear fzhu,

Could you please provide a screenshot of the issued screen? Thanks.

The replay web page doesn’t have any icon to let me upload image, how can I do this?

While moving your mouse cursor to the top-right corner of your comments, you should be able to find a paper clip icon, that can be used to attach file.
Or you can see a picture icon at the reply tool bar which is for your to upload the image file.


The screenshot is attached. It’s at end of first post. Thanks!

Hi fzhu,

Can you please explain more on how you start sdkmanager? Please let me know which of the following is your case.

  1. Are you using "ssh -X " command to remote connect to a Ubuntu 16.04 host machine, on which you’ve installed SDK Manager 0.9.9, then open sdkmanager in terminal window?
  2. Or you installed SDK Manager on a Ubuntu 16.04 host machine, and started SDK Manager on the same local machine?

Please also let me know

  1. How you started SDK manager?
  2. And provide the logs in ~/.nvsdkm/ directory.



I installed SDK Manager on a Ubuntu16.04 Host PC, and started SDK manager on the same Ubuntu16.04 Host PC by using sdkmanager command. And I uploaded the ~/.nvsdkm/sdkm.log in the post for your reference.

Thanks fzhu,

The log seems fine. Have you tried to reboot the machine then restart sdkmanager?

I reboot the host PC, and the result is same, no SDK manager GUI show up. please see attached sdkmlog2

Hi fzhu,
Could run below steps on your end?

  1. Download and install SDKM
  2. sdkmanager --spectron --disable-gpu --enable-logging -v=1 >& terminal.log
  3. Upload terminal.log and ~/.nvsdkm/sdkm.log
  4. What is the model of the graphics card? Do you have Node v11 installed on the host?


I followed your instruction to do step 1-3. and upload sdkm.log, terminal.log at the attachment.
I used geForce GTX 1080Ti video card(Nvidia) in my Host Ubunto16.04 PC.
I didn’t install Node V11 in my Host Ubuntu PC.


hi fzhu,
Thanks for providing the details. There is no issue found from the attached logs, app was already started per the log but just no window pop up.

I am not sure if it’s related to X11 forwarding configuration you have mentioned earlier in this post. Could you please try SDK Manager on a new setup Ubuntu 16.04 PC?


Hi fzhu,

Have you managed to flash your DRIVE AGX Xaiver system successfully?
Any result can be shared?