DriveAGX not connecting to network after updating to DriveOS v5.2.0

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
[+] DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[+] Linux

Hardware Platform
[+] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
[+] native Ubuntu 18.04


I just flashed my Target from DriveWorks 10.0 to DriveOS v5.2.0. After the flashing I am trying to finalize the DriveAGX System Setup but my internet is not working and not able to setup the target.

Can you please help me debug this issue? Thanks in advance.


some contexts in a topic from Connecting AGX to network - #6 by rborad.

Hi @pola5392 ,
If you can help @rborad here, that will be good. Thanks.

Hi @pola5392, I tried to fix the time using the RTC dongle. I see that system time is correct now. But It still is not connected to the network yet. Any ideas?

Thanks in advance.

@rborad Could you provide screenshots of your terminal after running timedatectl ? It is possible that the time zone is wrong. If I remember correctly, on the Drive OS 5.2 there was only one time zone available.

I wrote this down on my documentation whenever I fixed this problem on my machine. It might be helpful for you but take it with a grain of salt because I am not sure how much of this really contributed to fixing my issue and these aren’t official nvidia instructions.

In order to be able to download anything from the internet you will need to sync the true time to the Xavier chip that you are using. The time zone is set to UTC by default; you don’t need to change the time zone. Also, don’t be confused if you run timedatectl list-timezones and don’t get any time-zones in return because the version of Ubuntu that you are working with does not include them.

  1. Make sure that you set up the RTC module correctly by following the Hardware Quick Start Guide manual. The RTC module is used to keep track of time so if you cut power to the RTC module then you will need to reset the time again. Unless you use a NTP server but this would not be best practice. You have to keep in mind that the AGX is built to travel in vehicles and would not always have access to the internet to keep track of time.

  2. In order to insure that the time dependent on the RTC, run timedatectl set-local-rtc 1

  3. Now you can use timedatectl to set the time on the system. Note that the timezone is set to UTC so add 5 hours to the local time zone (Keep in mind this is different for your time zone) and use the command: sudo timedatectl set-time HH:MM:SS. Note that the hours are in 24hr format.

  4. Now you will need to set the correct time on the RTC.

  5. Use the bash shell to launch the script and get the time as follows: sudo bash /usr/local/sbin/ set

  6. Reboot your system and wait a couple of minutes for the computer to adjust to the real time.

  7. Once you’ve done that, do a quick apt update to ensure that the time is in sync. You should get not erros and the flags should be “[GET]”

Also, how are you checking that you are connected to the internet? Are you using apt-get or ping? If so, could you share the output from the terminal?


1 Like

Thank you for your reply @pola5392. You are right there is only one timezone. I am in PST timezone but i converted my current time to UTC. Is it a problem if my time is off by a few seconds?

Also, i am using both ping and apt-get update to check if device is connected to the network. I followed your instructions and confirmed that time in both my RTC as well as Target is in sync with UTC time. Still no luck

@VickNV, is there anything else I should be looking at? my eth0 port doesn’t have an IPv4 address (screenshot here). Is that a problem?

Dear @rborad,
I could see eth0 gets IP on my target. Have you connected ethernet via dual gbe dongle? Could you share network connection to target?

@SivaRamaKrishnaNV , thank you for the reply. Please find the picture attached here. As mentioned before. It was connected to the network when it was running DriveWorks 10.0 (same connections). Doesn’t work when i updated to DriveOS V5.2. I ran into this issue when I was trying to 1.4 Finalize Development Environment Setup. I tried to enable the display. My Display gets input from the Target but doesn’t display anything(blank screen). I am connected to the target using Minicom.

Let me know if you need better view or other views.


Dear @rborad,
This is strange. The connection seems to be correct. My board is not in UTC timezone. I could see eth0 IP, without any modification to networking files just after flashing. Do you notice any errors in flashing logs? Could you double check if Getting Started: DRIVE OS 5.2.0 :: DRIVE Platform Installation Guide with NVIDIA SDK Manager is followed.

@SivaRamaKrishnaNV ,

Thank you for the reply Siva.
There were some errors in the log file sdkm-2021-06-07-09-59-38.log (217.7 KB). Then I updated the SDK Manager to and errors reduced sdkm-2021-06-07-11-34-30.log (192.0 KB).

Did you want me to look at something specific from the link you shared above? It talks mostly about system requirements and HW setup. As mentioned before, I am using the setup that was connected to the Network when I was running DriveWorks10.0.

should I try installing earlier DriveOs version?

Let me know if you need more information.


I tried flashing my target with DriveWorks 10.0 and see if it connects to the network like before. And it doesn’t. This is strange. It used to work before and now it doesn’t after flashing again. Target acquires ipv4 address but no connection when trying to ping Also, Updated target time to UTC time.
Connections are same as before. Same Ethernet cable works great on my other computers.

Here is my network config info if it helps:

nvidia@tegra-ubuntu:~$ ip neighbour show dev eth0.200 INCOMPLETE dev enp4s0 FAILED
nvidia@tegra-ubuntu:~$ ip route list
default via dev enp4s0 proto static metric 2048 linkdown dev eth0 proto kernel scope link src dev eth0.200 proto kernel scope link src dev enp4s0 proto kernel scope link src linkdown dev eth0 proto kernel scope link src dev hv0 proto kernel scope link src dev eth0 scope link dev eth0 proto static
nvidia@tegra-ubuntu:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default _gateway UG 2048 0 0 enp4s0 U 0 0 0 eth0 U 0 0 0 eth0.200 U 0 0 0 enp4s0 U 0 0 0 eth0 U 0 0 0 hv0 UH 0 0 0 eth0 U 0 0 0 eth0

@VickNV @SivaRamaKrishnaNV Can you please help with this issue?? Isn’t this thing suppose to work out-of the box? Sorry but its taking way too long.

Dear @rborad,
My apologie for missing update.
DRIVE OS 5.2.0 → DRIVE SW 10.0 is not directly supported. Please see Getting Started: DRIVE OS 5.2.0 :: DRIVE Platform Installation Guide with NVIDIA SDK Manager . Please contact your NVIDIA representative for DRIVE OS 5.2.0 → DRIVE SW 10.0 migration.

Please remove ~/.nvsdkm folder and check flashing DRIVE OS 5.2.0 and share the complete logs(~/.nvsdkm/ folder). You need to complete the steps in Install DRIVE with SDK Manager :: DRIVE Platform Installation Guide with NVIDIA SDK Manager.

May I know if you notice board has any issue before flashing DRIVEOS 5.2.0? It is expected to work out of the box.

Hi @rborad ,

This is different from the original topic. Could you create a new topic for the issue of installing DRIVE Software 10 back from DRIVE OS 5.2.0? Thanks.

Dear @rborad,
Please check Vick’s suggestion in Downgrade DRIVE OS 5.2.0 to DRIVE Software 10 if you want to migrate DRIVE OS 5.2.0 → DRIVE SW 10.0. Please file a new topic if it does not fix with relevant flashing logs.