Driver 346 works while driver 384 fails to launch X server

Hi,
I have been trying to upgrade my driver from nvidia-346 to nvidia-384, but the second fails to launch X server.

Computer : Laptop MSI GE60 2PE Apache Pro
CPU : Intel I5-4200H
GPU : GeForce GTX 860M
System : Linux Mint 17.2 64bits
Linux core : 3.16.0-38-generic

Prime is supported, using nvidia-settings to force nvidia gpu use.

Driver 384.69 should be supported by my GPU, according to http://www.nvidia.fr/Download/index.aspx?lang=en

Here is how I change from 346 driver to 384 driver :
First going to virtual terminal (ctrl+alt+f1)
Then

sudo service mdm stop
sudo apt-get install nvidia-384 ((or nvidia-346 to restore to a working configuration))
sudo service mdm start

After installing nvidia-346 : the X server launch correctly, here is the /var/log/Xorg.0.log file after “mdm start” :
https://pastebin.com/CZkgfzSX

After installing nvidia-384 : the X server fails to launch, here is the /var/log/Xorg.0.log file after “mdm start” :
https://pastebin.com/crgJ6gCj --> Everything is similar to the first log until line 134

And here is the result of nvidia-bug-report.sh while driver 384 is installed :
https://pastebin.com/gq7TthDS

Why doesn’t the 384.69 driver works correctly ?

Thanks

I also tried manual installation of the driver downloaded from here (http://www.nvidia.fr/download/driverResults.aspx/123208/fr), but it also did not work.
Driver 361 worked on my computer, but it is not anymore there on linux mint repositories.
All driver > 361 did not work as well.
Installing recommended package libcuda1-384 and nvidia-opencl-icd-384 doesn’t help.

Edit : pastebin links also placed as attechement

Driver346_Xorg.0.log (32.3 KB)
Driver384_Xorg.0.log (13.7 KB)
nvidia-bug-report.log (231 KB)