Driver 516.40 Causing visual artifacts on Windows and Linux for Second Life viewers (OpenGL)

I’m having the same issue. Did not happen until after I updated my drivers today.

1 Like

Same issue here… just updated drivers to 516.40 for GeForce

My rig: Screenshot - 6e86cf290445637b33b6150010ba2539 - Gyazo

I am getting the exact same result, and this is not just the firestorm viewer, the Black Dragon viewer is having the same issue…
https://i.gyazo.com/99440c5a5f11ffd86e306e51a846222d.png

1 Like

Im having problems with newest driver when i play wolfenstein 2 new colossus ,my frame rates dropoed from 144 to 20fps for no reason

yes having the same issue with Firestorm after updating to this version, rolling back to previous version all works as it should.

Same issue with the latest Game Ready drivers and Windows 11.

1 Like

same issue! here drivers 516.40 WHQL / windows 11
firestorm viewer and official viewer. (Latest version).

1 Like

Same sepcs and same issue. Had to rollback to 512.95, this fixed the issue.

2 Likes

same issue here,
driver update causing visual artifacts such as lighting circles on my avatar (looks pretty cool, heh)
latest firestorm viewerx64 6.5.3.65658 & latest Official SL viewer (Open GL), same issues on both.

screen capture
Firestorm-Releasex64 6.5.3.65658 - CandyflossFifi - Google Chrome (gyazo.com)

windows 10 / drivers 516.40
advanced lighting enabled
ultra
LOD 2.5
draw 128

1 Like

Same driver version, exact same issues. Running Windows 11 22H2.
Additional issue: avatars flickering in and out of view, even when closeby.

Firestorm 6.5.3 (65658) Mar 1 2022 10:01:35 (64bit / SSE2) (Firestorm-Releasex64) with Havok support
Release Notes

CPU: AMD Ryzen Threadripper 3960X 24-Core Processor (3792.88 MHz)
Memory: 65410 MB
Concurrency: 48
OS Version: Microsoft Windows 11 64-bit (Build 22621.105)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: NVIDIA GeForce RTX 3080/PCIe/SSE2
Graphics Card Memory: 10240 MB

Windows Graphics Driver Version: 31.0.15.1640
OpenGL Version: 4.6.0 NVIDIA 516.40

libcurl Version: libcurl/7.54.1 OpenSSL/1.1.1l zlib/1.2.11 nghttp2/1.40.0
J2C Decoder Version: KDU v8.2
Audio Driver Version: FMOD Studio 2.02.05
Dullahan: 1.12.3.202111032221
CEF: 91.1.21+g9dd45fe+chromium-91.0.4472.114
Chromium: 91.0.4472.114
LibVLC Version: 3.0.16
Voice Server Version: Vivox 4.10.0000.32327

Settings mode: Firestorm
Viewer Skin: Firestorm (Dark)
Window size: 5120x2036 px
Font Used: Deja Vu (96 dpi)
Font Size Adjustment: 0 pt
UI Scaling: 1
Draw distance: 1024 m
Bandwidth: 1500 kbit/s
LOD factor: 4
Render quality: Ultra (7/7)
Advanced Lighting Model: Yes
Texture memory: Dynamic (4096 MB min / 30% Cache / 30% VRAM)
Disk cache: Max size 9984.0 MB (100.3% used)
Built with MSVC version 1916
Packets Lost: 0/2.825 (0,0%)
June 17 2022 02:54:12 SLT

My identical problem happens only when I have Advanced Lighting Model enabled.

I’m glad I’m not alone!

EDIT: Rolling back to 512.95 fixed the issue. Thank you, all.

2 Likes

I’ve got the same. Noticed it last night when I did an update. Turning Advanced lighting model off does make it go away but, I wouldn’t really consider that a “fix”… -shrugs-

Firestorm 6.5.3 (65658) Mar 1 2022 10:01:35 (64bit / SSE2) (Firestorm-Releasex64) with Havok support
Release Notes

You are at 234.3, 218.7, 31.4 in Serena Tempest located at simhost-04a83bbcb89e2d20f.agni
SLURL: Second Life Maps | Serena Tempest
(global coordinates 305,386.0, 292,571.0, 31.4)
Second Life Server 2022-05-27.572237
Release Notes

CPU: AMD Ryzen 7 3800X 8-Core Processor (4250 MHz)
Memory: 32717 MB
Concurrency: 16
OS Version: Microsoft Windows 10 64-bit (Build 19044.1766)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2
Graphics Card Memory: 8192 MB

Windows Graphics Driver Version: 31.0.15.1640
OpenGL Version: 4.6.0 NVIDIA 516.40

RestrainedLove API: RLV v3.4.3 / RLVa v2.4.2.65658
libcurl Version: libcurl/7.54.1 OpenSSL/1.1.1l zlib/1.2.11 nghttp2/1.40.0
J2C Decoder Version: KDU v8.2
Audio Driver Version: FMOD Studio 2.02.05
Dullahan: 1.12.3.202111032221
CEF: 91.1.21+g9dd45fe+chromium-91.0.4472.114
Chromium: 91.0.4472.114
LibVLC Version: 3.0.16
Voice Server Version: Not Connected
Settings mode: Firestorm
Viewer Skin: Firestorm (Grey)
Window size: 1920x1017 px
Font Used: Deja Vu (96 dpi)
Font Size Adjustment: 0 pt
UI Scaling: 1
Draw distance: 560 m
Bandwidth: 1450 kbit/s
LOD factor: 2
Render quality: High-Ultra (6/7)
Advanced Lighting Model: No
Texture memory: Dynamic (512 MB min / 10% Cache / 10% VRAM)
Disk cache: Max size 2048.0 MB (100.0% used)
Built with MSVC version 1916
Packets Lost: 0/32,861 (0.0%)
June 17 2022 09:18:44 SLT

1 Like

TYVM for the hint, had to struggle a little (never did a video rollback before) but rolling back to your same version saved my SL evening.

Same issue. I upgraded on one side for upgradign work as our Arallyn Roleplay will also be a Unreal 5 game.

However when I went to do an update in Secondlife on the sims, had the lines and flickering distant mesh objects and avatars. AN issue because of Opengl.

Secondlife does need to work on updating their viewer and opengl code, but this is a clear driver issue.

It has also happened when I view texel V code in unreal for some reason.

same issues here

same issues

Same results. same current reported drivers. thought it was firestorm settings at first, been happening since i updated drivers on 6/15

I used nvclean install to install an older driver, 512.95 in my case it has been working well so far if I have issues ill revert to an older driver for the time being. It also allows you to create a driver installer if someone less tech-savvy needs a driver, I typically use the installers by NVIDIA but in this case till they can fix the issues this is a fairly easy work around till they fix the issue, i am going to tell you it might cause your framerates to drop a bit ,but its the most elegant and clean solution ive found so far

The 516.59 drivers that were released today appear to address this issue. Inara Pey’s blog post has more details.

I have confirmed that I no longer see the artefacts once I have installed the latest drivers (Win11). Tested on both the current Firestorm release and an unreleased development build.

Thank you nvidia team for a quick fix (and thank you Minecraft for being affected too as I suspect that helped the motivation :-)

ver 516.59 was release today 28/06/2022 which seems to have fixed the problems with the previous driver, on Windows 10.