Driver help, please.

Hello,

I am seeking assistance regarding Linux/Ubuntu drivers for my card, which is GeForce Sparkle 6600 LE 256mb card. I have Ubuntu 12.04 and no matter which driver I install, I get errors for OpenGL support, and white screens at boot up after installation.

I have no idea how to find the appropriate driver. Any and all help is greatly appreciated.

Thank you!

Hello,

I guess this is a bump. I am desperate for any and all help. The driver I tried from the official page is “304.64”. Is this the wrong driver?

Thanks!

I think you should use legacy drivers like this
depending on your ubuntu 32 or 64 bit
x86
http://www.nvidia.com/object/linux-display-ia32-173.14.36-driver.html

or
x64
http://www.nvidia.com/object/linux-display-amd64-173.14.36-driver.html

@rusty1: Nope, 304.64 is the correct driver for Geforce 6/7 cards.

@Tumbar: More info is needed. Did you install from packages provided by the distribution or a PPA? That’s usually a better option than using the Nvidia installer. In any case, the stickies at this forum explain how to create a bug report. Do that.

Hello and thank you for the replies,

@Gusar; I first installed manually from the drivers off the site. It took a while to get everything sorted, but it said it installed because the Nvidia x settings window gave me the correct driver. However, trying to open applications/programs that required or had some features that required OpenGL would tell me that my card currently does not support OpenGL.

So then, after a reboot, it appeared to have broken my system. So I did a fresh install of Linux Mint (and Ubuntu, as I more like triple boot) and attempted to install one from the Mint collection of drivers, the “recommended” one, but it forced me to accept very small resolutions and still had the same problems as before. So, for now, I reinstalled the first way–that is, manually from the CLI with drivers from the site. Linux Mint runs fine now, but still no OpenGL and a very, very long error log at the start of every boot appears.

I’m not sure how I would make a report bug out of what is happening through the methods it requests, but I have contacted Nvidia’s support three days ago about the issue. However, just in case they happen upon this thread for either assistance or the need of the report, I will attach the logs momentarily.

@rusty1; in an act of desperation, I sought to using another (the one you linked to) driver that said it supported series 6 because I heard it might be my X server that is the problem, but I resulted in the exact problems.

Thanks,

Hello,

Since I cannot edit, here is the log file from nvidiai saying it installed fine the second attempt which is what I am currently using;
http://pastebin.com/gCNHPBNX

And the Xorg.0.log file;
http://pastebin.com/k8KN6Pqa

Besides that, I don’t get any errors in computer besides the “your card either doesn’t support OpenGL or you need to update your drivers”. It makes no log, so I cannot provide it. I do get errors with the GPU in the computer at start up and but not inside…if I’m lucky enough to get inside the PC.

Thanks,

EDIT:

After taking the GPU out, the computer boots in fine using on board GPU with NVIDIA GeForce 6150SE nForce 430, which seems to be supported by the same driver. So I guess it is the driver for the card or the lack of full support for this one card, or something. Any help?

just a thought, have you disabled onboard gpu when using your 6600 LE ? also check this
here is more latest drivers than on the previous site I gave you.

x64
ftp://download.nvidia.com/XFree86/Linux-x86_64/

also try a different distro like Cinnarch with an updated xorg 1.13.1
check this site
http://ubuntuxtreme.com/howto/how-to-install-nvidia-drivers-304-64/

Hello and thanks for the reply, rusty1,

No, I have not done that. I did know I could, actually. How can I go about that? Thank you for the link, too, rusty1. At this point I will literally try anything as long as it won’t hurt my mobo. Which should I download, and how can I tell which is a 32bit download? Seems like there is only a 64bit download list. If that is all they have then I could install Ubuntu 12.04 fresh as a 64bit OS.

I have not yet tried Cinnarch (looks great! I love Cinnamon!), but here is a list of all distros I have tried; Ubuntu 12.04 (completely totals everything), Linux Mint (using now), and Kubuntu (refuses to open at all now). I was going to try Linux Arch, but it refuses to install for me freshly. I will download and burn Cinnarch to try next. Is there any tut on installing nvidia drivers available for it?

As for the site at the end, I have tried that one too. I tried their script, same problems, and then their instructions on manual installation, but I got the same results in all distros and all manners of installation.

My thanks,

EDIT:

Running the command “jockey-text --list”, right now with no GPU in, gives me this;

kmod:nvidia_experimental_304 - Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
kmod:nvidia_173 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
kmod:nvidia_current - nvidia_current (Free, Enabled, Not in use)
kmod:nvidia_current_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
kmod:nvidia_173_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)

Since I cannot get into the computer with the GPU in, I cannot give the output of the file sadly…

check distrowatch.com for all your linux distros. which ubuntu or linux mint you’re running ? if it’s x64 then you need a 64 bit nvidia driver if not then 32 bit.
You can look up if it’s 32 or 64 bit in “System Monitor”
for Cinnarch installation check youtube

Hello,

I am running Linux Mint 14 Nadia with Cinnamon, 32bit. As for Ubuntu 12.04, I am running 64bit fresh install with the beta drivers selected from “Additional Drivers”.

xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
xorg:nvidia_173_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
xorg:nvidia_96 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
xorg:nvidia_experimental_304 - NVIDIA accelerated graphics driver (**experimental** beta) (Proprietary, Enabled, In use)

Which is 304.48, instead of the newer 304.64.

I figured I should try 64 bit on 12.04 because I read on a forum to try 64bit if you have an AMD Athlon II processor.

I most definitely will, especially if Kubuntu continues to not work.

My thanks,

Hello,

As said before, removing the GPU lets me boot into all the distros effected. So I guess it is the driver for the card or the lack of full support for this one card, or something. For now, the following distros have the exact problem; Ubuntu, Kubuntu, Linux Mint, Manjaro, Edbuntu, Xubuntu, and Fedora. Except in Manjora the installation pre-installed the exact driver I needed, so that was very helpful for my board GPU, however, can’t use my external GPU so I can’t perform any high applications or play videos above 300p.

This is disappointing, but I am glad it appears not to be a problem with the distros itself. At least that’s how it seems. Any help, or ideas?

Hello,

New update. Installing 304.64 finally worked in Ubuntu 12.04 and I am willing to share the process if it will help determine why it happens and why it is broken, but it has not allowed the GPU to work even if updated to the current release. This is definitely a problem on the driver’s end for the same card works flawlessly on Windows 7.

If it isn’t the drivers I would really, really like hearing from support or someone on this issue. I cannot perform any tasks without my GPU and I currently do not have the funds to dish out to get a new GPU that “might” work with Linux. Though, to be honest, I am building a new rig but I will not have that for some time and I cannot afford not having a workable computer until then.

Thank you,

so what’s happenning ? did you try x64 ubuntu ?

Hello,

Yes, I am using 64bit Ubuntu currently, which seems to have been the only that would allow me to install the update to date driver manually, otherwise I Was given access problems or conflict problems. As for what is happening, I have 304.64 driver installed and everything seems to be in order (other than being asked to update my driver through Additional Drivers). However, as soon as I put my GPU into the system, no distro will boot up and I am given static screens, black screens and more. I am never presented with a boot or grub screen. But if I take the card out then the system boots in fine.

My thanks,

Hello,

After tireless attempts at resolving this issue for what is going on for three weeks now, I realized the GPU is not supported despite saying it is. I have met another person with the exact issues, and another who uses a LE card that as the same issues.

Things I recently tried;

  • Edit the BIOS to the GPU slot (allowed me to boot past the Ubuntu logo screen, but presented me with the same issues)
  • Enabling VT via BIOS
  • Installing the distros with the GPU in (would not let me)
  • Tried all LE drivers
  • Tried 64 and 32 bit drivers and distros

Can we at least look forward to seeing an update of the LE drivers so our cards can be supported in Linux, or are we stuck gaming in Windows?

My thanks,

Update!

I have tested my thoughts out before I posted them here. It turns out that old LE cards will DIE if you attempt to update your drivers via Ubuntu or another distro. By LE and old I mean cards like the GeForce Sparkle 6600 LE and older. I tested it on another 6600 LE card and it killed it as well.

They both worked in Windows with the recent drivers. Now if I attempt to load into windows with the GPU/s in, I get blue screens concerning nvlddmkm, horrid pixelized boot screens and no boot up past the Windows Start menu (black screen with logo). The card also gets very hot and if booted into safe mode, refuses to detect and reports–through various programs–that there is something wrong with the GPU/s.

So I repeat; if you have an old LE card, don’t risk it. Unless you want to of course.