Enable SLI for Unreal Engine 4.15.1 project

Hello all,

Epic released Unreal Engine 4.15.0 & 4.15.1 which claim to now support SLI, however; their notes say that the developer has to work with NVidia for this, and those that I’ve seen trying to do so, get pointed here.

So here I am. With basically the same question as posted in this topic:
https://devtalk.nvidia.com/default/topic/995586/?comment=5092137

I’m working on a UE project, and we’re still a ways from being in release, but we have numerous public testers with SLI setups, including one of my own rigs with a pair of 970 GTX’s.

From what I have gathered, in order for the game to use SLI, it simply needs a profile from NVidia.

  1. How does one go about getting an NVidia game profile created with SLI support?
  2. What would invalidate the profile? For example, our binaries change rather frequently as we update our game code; would this negate the profile if we had one created?
  3. If the 2nd item holds; at what point would be a good time to get the profile so developers could test before release?

half figured this out myself…

I still don’t know how to go about getting an official Nvidia Profile, but I did find out that end users can do this themselves thanks to the help of this (dated) article:
http://www.nvidia.co.uk/docs/IO/83809/instructions.pdf

While the Screen shots are out of date, the process is essentially the same.

  1. Add Game Binary to the "Programs List" under 3D management
  2. With the game selected, scroll through the options to "SLI Rendering Mode" (this will only appear on systems that have SLI enabled)
  3. Change the setting from the default "Use Global Setting" to your desired SLI mode. For my UE project, this was "Alternative Frame Rate 2"