Enabling I2C4 on Xavier Devkit

I am having issues using I2C4 (controller i2c@c250000).

If I use a device tree with a device setup on I2C4 there are timeouts and read errors during boot.
If I leave the device disabled in the device tree and try to do an i2cdetect on the bus it just goes very slow and errors out.

The same device on a different bus works fine so I am confident the device tree and driver are working properly. It seems to be something on the Xavier side.

Any ideas?

Hi, are you testing on dev kit or custom board? If custom board, what’s the difference to dev kit on this part?

Hi pnewmanCTI,

Is this still an issue to support? Or issue has been resolved?


Hi kayccc,
Yes it is a custom board and the difference is we have an I2C expander connected to it. We have another I 2C expander that is identical on a different I2C bus and it works fine.

And yes it is still a support issue.

The controller might actually be i2c@31e0000 I am not sure. I have tried both.

I have also tried multiple boards so the issue doesn’t seem to be hardware related.