Error after Setting up Conda Environment

I have this error after setting up Conda Environment:
2024-02-22 10:59:00 [716ms] [Error] [omni.ext._impl.custom_importer] Failed to import python module omni.pip.torch.tests. Error: No module named ‘psutil’. Traceback:
Traceback (most recent call last):
File “/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/kernel/py/omni/ext/_impl/”, line 76, in import_module
return importlib.import_module(name)
File “/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/python/lib/python3.10/importlib/”, line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 1050, in _gcd_import
File “”, line 1027, in _find_and_load
File “”, line 1006, in _find_and_load_unlocked
File “”, line 688, in _load_unlocked
File “”, line 883, in exec_module
File “”, line 241, in _call_with_frames_removed
File “/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/extscache/omni.pip.torch-2_0_1-2.0.2+105.1.lx64/omni/pip/torch/tests/”, line 11, in
from .test_torch_2_0_1 import *
File “/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/extscache/omni.pip.torch-2_0_1-2.0.2+105.1.lx64/omni/pip/torch/tests/”, line 14, in
import omni.kit.test
File “/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/exts/omni.kit.test/omni/kit/test/”, line 5, in
from .async_unittest import AsyncTestCase
File “/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/exts/omni.kit.test/omni/kit/test/”, line 22, in
from .reporter import TestReporter
File “/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/exts/omni.kit.test/omni/kit/test/”, line 21, in
import psutil
ModuleNotFoundError: No module named ‘psutil’

2024-02-22 10:59:00 [716ms] [Error] [carb.scripting-python.plugin] Exception: Extension python module: ‘omni.pip.torch.tests’ in ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/extscache/omni.pip.torch-2_0_1-2.0.2+105.1.lx64’ failed to load.

/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/kernel/py/omni/ext/_impl/ startup
/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/kernel/py/omni/ext/_impl/ startup_extension

2024-02-22 10:59:00 [716ms] [Error] [omni.ext.plugin] [ext: omni.pip.torch-2_0_1-2.0.2] Failed to startup python extension.

Any suggestion what caused the problem?

@ahn.paf i am just another user passing by, and to recall from another thread, one of the mods has pointed out a few potential causes when facing failed to import python module messages:

hopefully this is somewhat relevant.

I am just simply run isaac sim so there is no module to be installed.
I also get these Python environment when I run the code in python shipped with isaac sim:
~/.local/share/ov/pkg/isaac_sim-2023.1.1$ ./
Warning: running in conda env, please deactivate before executing this script
If conda is desired please source in your python 3.10 conda env and run python normally
Python 3.10.13 (main, Oct 18 2023, 20:21:26) [GCC 7.3.1 20180303 (Red Hat 7.3.1-5)] on linux
Type “help”, “copyright”, “credits” or “license” for more information.

import sys
[‘’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1’, ‘/home/amirhossein/.local/share’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/exts/omni.isaac.kit’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/exts/omni.isaac.gym’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/kernel/py’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/plugins/bindings-python’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/exts/omni.isaac.lula/pip_prebundle’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/exts/omni.exporter.urdf/pip_prebundle’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/exts/omni.kit.pip_archive/pip_prebundle’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/exts/omni.isaac.core_archive/pip_prebundle’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/exts/omni.isaac.ml_archive/pip_prebundle’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/exts/omni.pip.compute/pip_prebundle’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/exts/’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/extscache/omni.pip.torch-2_0_1-2.0.2+105.1.lx64/torch-2-0-1’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/python/lib/python3.10/site-packages’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/python/lib/’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/python/lib/python3.10’, ‘/home/amirhossein/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/python/lib/python3.10/lib-dynload’, ‘/home/amirhossein/.local/lib/python3.10/site-packages’]
The other two options are not related too! So I think everything here works fine!

It is also notable that I have no issue running the 2022 version of the Isaac-sim! after installing the requirements of Isaac orbit and Isaac conda environment I am encountering these strange errors!

Hi, I was facing the same error. Something about orbit’s installation seems to break Isaac Sim. Nothing in Isaac Sim was working anymore, i.e., the Isaac Sim tabs were missing, the browser was limited to the desktop and I had no way of accessing the file system, the cache did not turn on…

What solved it for me was upgrading pip and then installing psutil.
For this, go to the root of your Isaac Sim installation and run the following:

./ -m pip install --upgrade pip
./ -m pip install psutil

Hope this helps :)


I have actually uninstall orbit and install isaac sim again!
The other problem I am currently facing is orbit would stuck which I mentioned in the post earlier.
I just had one time oppurtunity to run first example in orbit which took me about 45 minutes to load!

Should they mention this in their docs? I suspect that would be a case for 2023 version of isaac sim! Because my isaac was clean and new and I followed every step of docs to install orbit! Do you have any opinion about the performance?


Yes, we noticed this recently. The issue started with dependent libraries (RL-Games) did a dependency upgrade of psutil to 5.9, while Kit uses 5.7. Due to this, Omniverse is unable to find psutil and you have to manually install it again.

Please check the discussion here on GitHub: Isaac sim doesn't function normally after installing Orbit · Issue #194 · NVIDIA-Omniverse/orbit · GitHub

@ahn.paf, the issue with it taking 45 minutes to start is new to us. Can you please open an issue on GitHub with further details on your system configuration? We can start investigating it from there. But very likely, this has to do with your internet and Nucleus server connection.