"ModuleNotFoundError: No module named 'omni.isaac'" Isaac Sim 2023.1.1 SimulationApp

Hi there,
so far I used Isaac Sim Version 2022.2.1 built in python environment without any problems.
By updating to 2023.1.1 via Omniverse Launcher and using the built in python environment I get ModuleNotFoundError: No module named ‘omni.isaac’ error for all scripts i try to run and import omni.isaac.kit SimmulationApp.

Running for example the standalone_examples/api/omni.isaac.kit/hello_world.py
with:

source setup_python_env.sh
./python.sh standalone_examples/api/omni.isaac.kit/hello_world.py 

i get the following error:

  File "/home/<user>/.local/share/ov/pkg/isaac_sim-2023.1.1/standalone_examples/api/omni.isaac.kit/hello_world.py", line 11, in <module>
    from omni.isaac.kit import SimulationApp
ModuleNotFoundError: No module named 'omni.isaac'

I have already tried reinstalling Isaac Sim but it had no impact.

@feneu005 i am just another user passing by, not sure if the below threads from the past are relevant to some extent?

@Simplychenable thanks for your advice.

I think something went wrong during the isaac sim post installation.
When reinstalling Isaac sim, I always have to skip the post installation, since it’s otherwise running for hours without finishing (last time 4h).


Looking at the omni.isaac.sim.post.install.log the same error occurs that the module ‘omni.isaac’ is not found.
omni.isaac.sim.post.install.log (69.3 KB)

if it’s related to installation to the newer versions, there’s a pinned thread where the mods mentioned two possible scenarios:

see if that provides some relevant information since the log seem to indicate it’s related to missing library dependencies.

I solved the error: I had the same issue as in this post and solved it the same way
https://forums.developer.nvidia.com/t/no-module-named-omni-isaac/197312/8?u=feneu005