Error: CUDA-capable GPU was not found

Hi i am using
Linux Tera+ 3.10.96-tegra #1 SMP PREEMPT Tue May 17 16:29:05 PDT 2016 aarch64 aarch64 aarch64 GNU/Linux
I have both CUDA 8 and 7 installed am in a using other projects.

I am getting following error while running Visionworks Samples

VisionWorks library info:
	 VisionWorks version : 1.5.3
	 OpenVX Standard version : 1.1.0

Error: CUDA-capable GPU was not found.

Hi raak,

It seems something mismatch in your environment, what shows up under:

sudo dpkg --list | egrep -i '(nvidia|cuda)'

Thanks

Yes issue is fixed thanks

Hi raak,

Thanks for your update, it’s good to know that issue got resolved.
If someone met the same issue, they could fix it by following your guidance.
Would you mind to share how you fixed it?

Thanks

Hi Kaycc.

Our TX1 runs Ubuntu 14:04(Custom Version) we have installed both Cuda7 and 8 and visionworks 1.5.3
we have re flashed and installed only Cuda 8 and Visionworks 1.5.3.

Regards

I have the same issue with L4T 28.1 (3rd party customized) + CUDA 9.0 tool kit + VisionWorks 1.6.0 combination.
I tried to downgrade CUDA to 8.0 because some threads in the forum indicated CUDA 9.0 would not work with L4T 28.1 (JetPack 3.1).

However, the after I installed CUDA 8.0 and re-install VisionWorks 1.6.0 again, the latest VisionWorks package “libvisionworks-repo_1.6.0.233n_arm64_l4t-r26.deb” refused to be installed with the error message “CUDA >= 9.0 is required” even though official VisionWorks document says VisionWorks 1.6.0 should work with CUDA 8.0.

https://developer.download.nvidia.com/assets/embedded/secure/jetson/TX2/r27_Release_v1.0/VisionWorks/VisionWorks-1.6-README-Linux.txt?4wQmdyqYo7-XpG7Jh2F0huKCLGI11lEn_OF7q_fUi7apnZGLL5KVwJ3JKUeLd3CPBxHnZ9pZ6VyvgVlCgaZe6jryRlj3NXN-2rGRpsUXNgY1V9lfgPKQ9mzY7bseRvA4d7S_Vc8lEU2p1RmqMIMHwxXr9jI1zLfz7wLAZ1rJVzKgZG-K0qdH_dRJ-Ng6odilaqg_tT3imbjR_pVAPHg

Could anyone tell me how I would be able to download earlier VisionWorks 1.6.0 package which accepts CUDA 8.0?

I found the root cause of my case.
VisionWorks itself was not the matter.

libvisionworks-samples, libvisionworks-sfm, libvisionworks-tracking depend on cudart-9-0 and they prevented libvisionworks installation with cuda 8.0.
I unchecked samples, sfm and tracking installation on JetPack 3.1 installer and successfully installed & was able to run VisionWorks 1.6.0 with CUDA 8.0.

Thanks.