Error in pbrun deepvariant command. (with --channel-gc-content)

I am using pbrun deepvariant command (with --channel-gc-content):
(NVIDIA Parabricks Container 4.2.0-1)

pbrun deepvariant --channel-gc-content --mode ont
–ref /workdir/parabricks_sample/Ref/Homo_sapiens_assembly38.fasta
–in-bam /outputdir/bamsort_output.bam
–out-variants /outputdir/deepvariant_output.vcf \

I get the following output (message):

[src/] The dimension of model file doesn’t match with the confirguation.
Model:100,199,9. Confirguation:100,199,10, exiting.

Wrong option?
Please advise. (or sample command example.)

Hi @M.Fukasawa,

You will need to get rid of the --channel-gc-content flag if you want to run DeepVariant with the default model. It’s not very clear in the documentation (I will put in a request to rectify that), but if you want to use that flag, you’d have to train and bring your own deepvariant model.

Hi @gburnett, Thank you for your answer.
I had the same situation with the options below.


Is it the same reason?
Please advise.