Error occurs when using deepstream-test5-app output to amqp

Please provide complete information as applicable to your setup.

• Jetson Xavier AGX
• Deepstream 5.0.1
• Jetpack 4.4
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type ( questions)
**• How to reproduce the issue ? **

Hi. To send output message to rabbitmq, I modified configuration file test5_config_file_src_infer.txt sink, detail listed below.

[sink1]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File 4=UDPSink 5=nvoverlaysink 6=MsgConvBroker
type=6
msg-conv-config=dstest5_msgconv_sample_config.txt
msg-conv-payload-type=0
msg-broker-proto-lib=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_amqp_proto.so
#Provide your msg-broker-conn-str here
msg-broker-conn-str=10.180.149.96;5672;quickstart-events

Then
Run the cpp file using:
$sudo deepstream-test5-app -c test5_config_file_src_infer.txt

Detail of occured error is listed below:

(deepstream-test5-app:11469): GLib-CRITICAL **: 16:15:06.677: g_strchug: assertion ‘string != NULL’ failed
(deepstream-test5-app:11469): GLib-CRITICAL **: 16:15:06.677: g_strchomp: assertion ‘string != NULL’ failed
Warning: ‘input-dims’ parameter has been deprecated. Use ‘infer-dims’ instead.
** ERROR: main:1451: Failed to set pipeline to PAUSED
Quitting
ERROR from sink_sub_bin_sink2: Could not initialize supporting library.
Debug info: /dvs/git/dirty/git-master_linux/deepstream/sdk/src/gst-plugins/gst-nvmsgbroker/gstnvmsgbroker.c(359): legacy_gst_nvmsgbroker_start (): /GstPipeline:pipeline/GstBin:sink_sub_bin2/GstNvMsgBroker:sink_sub_bin_sink2:
unable to open shared library
ERROR from sink_sub_bin_sink2: GStreamer error: state change failed and some element failed to post a proper error message with the reason for the failure.
Debug info: gstbasesink.c(5265): gst_base_sink_change_state (): /GstPipeline:pipeline/GstBin:sink_sub_bin2/GstNvMsgBroker:sink_sub_bin_sink2:
Failed to start
App run failed

How to configure test5_config_file_src_infer.txt correctly? Thanks.

Hi,
msg-broker-conn-str=10.180.149.96;5672;quickstart-events

should be like this format: “url;port;username;password”
please change the last part quickstart-events, to username, passwd, and add one property topic in the config, also make sure you build the rabbitmq library and copy the library to /opt/nvidia/deepstream/deepstream-/lib/
refer to sources/libs/amqp_protocol_adaptor/README for how to build it.
please let me know if this will fix your issue.