Error reading from Serial Device, Incorrect credentials

I was configuring Jeson AGX Orin in a Windows PC using PuTTy software.
While configuring, at the time of “Installing System”, got the error “Error reading from Serial Device” and stopped. May be due to power fluctuation.
After that, I powered off and powered on.
Thereafter, it says Login Incorrect, even though I have given correct credentials.

Later, I pressed the Reset button and started the connection again, its asking for Login credentials. And same error is coming, “Login Credentials Incorrect”.

Requesting support to configure the Jetson AGX orin board again.

We would suggest use host PC with Ubuntu 18.04 or 20.04. It is not supported to use host in Windows OS.

I tried using Ubuntu 20.04.
The same error “Login Incorrect” came. Screenshot attached.
Please help to resolve this issue.

Would suggest install SDKManager on the host PC, connect Orin to host PC, let Orin enter recovery mode and re-flash Orin. At first booting you can create user/password through Ubuntu GUI.

I tried through SDK Manager and got the below error message.
“Default ip is not available. Use a customer ip instead.” Screenshot below.
Kindly support to resolve the issue.

You wouldn’t need to flash again for this test, but if you run “dmesg --follow”, and note the last log entry, what gets added when you insert the USB flash cable from the Jetson, but boot normally rather than in recovery mode? My hope is that it shows some sort of log regarding the network device (it is a virtual network device over USB provided by a fully booted Jetson). It might be the host PC simply needs to be told to allow the connection. Also, at the moment of the log if a virtual device does appear, show the host PC’s output from commands “ifconfig” and “route”.

Please select Manual Setup in step 1 and Runtime in step 5. To flash the system image and make sure it can boot to Ubuntu GUI. And then you can follow the GUI to set up user/password.

Through the SDKManager, I have flashed the system image by selecting the Manual Setup.
After that, the Jetson board is not getting detected in the command dmesg | grep --color ‘tty’
Ubuntu GUI is not coming. At present, not able to perform “oem-configuration”, that is, Ubuntu System Configuration.
Also observed that, after flashing, the Jetson board gets detected in the SDKManager, only in Recovery mode. Kindly support.

Please use the micro usb console to tell whether the device is booting up or not.

After flashing, your board shall not be in RCM…

If you let Orin enter recovery mode, select Manual Setup in step 1 and Runtime
in step 5, are you able to proceed and flash Orin?

I am able to flash Orin in Manual Setup with Runtime in step 5.
For this, I used C type cable.

After finishing the flash, I powered off the board and powered on again.
The board was not getting detected through the below list command.
$ ls -l /dev/ttyACM0

So, I connected the MicroUSB and tried again. This time the below list command worked.
$ ls -l /dev/ttyACM0

When I put the below screen command, I got the message as shown in screenshot.
sudo screen /dev/ttyACM0 115200

Yesterday, I flashed Orin in Manual Setup with PreConfig in step 5. Then checked the screen command yesterday. sudo screen /dev/ttyACM0 115200
Was able to put the login credentials and it was accepting. But the system configuration was not coming.

Kindly support.

Flashing the runtime was successful.
I was not able to proceed further by connecting the board to Laptop.
So, instead of the laptop, connected a keyboard, mouse and monitor to the board.
Now I am able to enter into Ubuntu OS and create user configuration.
Then through the terminal, installed the necessary packages.
Thanks for your support.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.