Error running dwSAL_createSensor

Software Version
DRIVE OS Linux 5.2.0 and DriveWorks 3.5

Target Operating System
Linux

Hardware Platform
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version
1.4.0.7363

Host Machine Version
native Ubuntu 18.04

Hey,
So I’m trying to run some code that uses dwSAL_createSensor, but I’m getting an error.
When I tried using the basic sample_camera executable, I got the following error:

nvidia@tegra-ubuntu:/usr/local/driveworks/bin$ ./sample_camera --rig=/usr/local/driveworks/data/samples/sensors/camera/camera/rig.json
[21-09-2019 06:33:15] Platform: Detected DDPX - Tegra A
[21-09-2019 06:33:15] TimeSource: monotonic epoch time offset is 1569027511212199
[21-09-2019 06:33:15] PTP Time is available from NVPPS Driver
[21-09-2019 06:33:15] Platform: number of GPU devices detected 2
[21-09-2019 06:33:15] Platform: currently selected GPU device discrete ID 0
[21-09-2019 06:33:15] Context::getDataPathFromSelfLocation DATA_ROOT found at: /usr/local/driveworks-3.5/data
[21-09-2019 06:33:15] SDK: No resources(.pak) mounted, some modules will not function properly
[21-09-2019 06:33:15] SDK: Create NvMediaDevice
[21-09-2019 06:33:15] SDK: Create NvMedia2D
[21-09-2019 06:33:15] SDK: use EGL display as provided
[21-09-2019 06:33:15] TimeSource: monotonic epoch time offset is 1569027511212199
[21-09-2019 06:33:15] PTP Time is available from NVPPS Driver
[21-09-2019 06:33:15] Initialize DriveWorks SDK v3.5.75
[21-09-2019 06:33:15] Release build with GNU 7.3.1 from heads/buildbrain-branch-0-gc61a9a35bd0 against Drive PDK v5.2.0.0
[21-09-2019 06:33:15] Rig::fromFile: Loading rig file: /usr/local/driveworks/data/samples/sensors/camera/camera/rig.json
[21-09-2019 06:33:15] No valid data file found for camera:sample0 in parameter string: camera-name=SF3324,interface=csi-a,link=0,output-format=processed (using configuration folder /usr/local/driveworks/data/samples/sensors/camera/camera/)
onInitialize: creating camera.gmsl with params: camera-name=SF3324,interface=csi-a,link=0,output-format=processed
[21-09-2019 06:33:15] SensorFactory::createSensor() -> camera.gmsl, camera-name=SF3324,interface=csi-a,link=0,output-format=processed
[21-09-2019 06:33:15] CameraBase: pool size set to 8
[21-09-2019 06:33:15] SensorFactory::createSensor() -> camera.gmsl.master, 
libnvsipl_query.so: CNvMCameraModuleInfo.cpp : 76: ParseJson: Could not find matching serializer
libnvsipl_query.so: CNvMDeviceInfoList.cpp : 100: GetCustomCameraModule: Failed to find matching module MAX96712TPG
libnvsipl_query.so: CNvMDeviceBlockInfo.cpp : 156: ParseJson: Failed to find matching camera module
libnvsipl_query.so: CNvMPlatformCfgInfo.cpp : 50: ParseJson: CNvMPlatformCfgInfo::ParseJson failed.
libnvsipl_query.so: CNvMQuery.cpp : 45: ParsePlatformConfig: Failed to parse a PlatformCfg
[21-09-2019 06:33:15] CameraMaster::parseDevBlock Getting device info list.
[21-09-2019 06:33:15] devBlock: 1 Slave = 0 Interface = csi-a Camera_name = SF3324 Link = 0
[21-09-2019 06:33:15] std::exception thrown: std::bad_alloc
terminate called after throwing an instance of 'std::runtime_error'
  what():  [2019-09-21 06:33:15] DW Error DW_FAILURE executing DW function:
 dwSAL_createSensor(&m_camera[m_totalCameras], paramsClient, m_sal)
 at /dvs/git/dirty/gitlab-master_av/dw/sdk/samples/sensors/camera/camera/main.cpp:234
Aborted (core dumped) 

Worth to mention that the code worked on DRIVE OS 5.1.9 and driveworks 2.2
Thank you!

Dear @eladg1,
Do you mean it worked on DRIVE SW 10 release(it has DW 2.2+ DRIVE OS 5.1.6)?

Exactly.

Dear @eladg1 ,
Could you confirm if you are using SF3324 camera module?

Yes that’s true

Dear @eladg1 ,
I am assuming you have installed the DRIVE release via sdkmanager using developer.nvidia.com credentials.
Could you please run sipl_query and share log. Please check DriveWorks SDK Reference: SIPL Query Tool

We decided to downgrade back to DRIVE OS 5.1.6.1 and DriveWorks 2.2

Dear @eladg1 ,
The reason is because of above issue? Could you share the sipl_query if possible? We will investigate furthur. This model is expected to work on DRIVEOS 5.2.0.

Yes, it is due to the above issue. However, we cannot currently “roll back” to version 5.2.0.