Error running the roadrunner preinstalled dataset

Please provide the following info:
Hardware Platform: DRIVE AGX Xavier™ Developer Kit
Software Version: DRIVE Software 10
Host Machine Version: native Ubuntu 18.04
SDK Manager Version:
Hello, when trying to test the roadrunner examples with the preinstalled datasets I encounter an error.
when trying the command:
./ --car onofframp --product sl2 --gui on-a
trying any dataset brings the same error, and playing with the possible parameters bring the same errors as well.
I must mention that running the ./roadrunner from bin is working.
another thing that bothers me is that yesterday I tried the “debug visualization” that uses the same shell but with slightly different parameters and it did work yesterday.
but today using the same command causes errors.
the problem is that I’m not very sure what the error means, I noticed mostly the error “Unable to bind socket to port”
which doesnt tell me much. (maybe port is on use? - but which one?)

Would appreciate any help.
Thanks in advance.

Hi @mikepo2808,

That’s because roadrunner is already running in the background.
Please try again after issuing the command:

$ /usr/local/service-framework/scripts/


1 Like