ERROR: Unable to find display on any available system

i get this error message ERROR: Unable to find display on any available system when i tried to run nvidia-settings. after i install the .run file is there anything else i need to do to configure the drivers?

im using debian testing.

For a quick shot, make sure that you disabled secure boot in bios. Otherwise, please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

i have the same problem. In my case, I only updated several OS packages with pacman. One of them was the nvidia driver.
nvidia-bug-report.log.gz (1.1 MB)

braulio2791, there are no current xorg logs, happen to run a wayland session? Which DE/DM are you running? Since you have an Optimus notebook, please delete /etc/X11/xorg.conf.d/20-nvidia.conf

the display server is X Server 1.20.5 + Wayland. I’m running the gdm. I already deleted the file …/20-nvidia.conf. The only way to get open the nvidia-settings is with the following command:
$ optirun -b none nvidia-settings -c :8

Please post the output of
xrandr --verbose

I’m working with two monitors.
$ xrand --verbose
Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
XWAYLAND0 connected 1920x1080+0+0 (0x22) normal (normal left inverted right x axis y axis) 340mm x 190mm
Identifier: 0x21
Timestamp: 47805
Subpixel: unknown
Gamma: 1.0:1.0:1.0
Brightness: 0.0
Clones:
CRTC: 0
CRTCs: 0
Transform: 1.000000 0.000000 0.000000
0.000000 1.000000 0.000000
0.000000 0.000000 1.000000
filter:
non-desktop: 0
supported: 0, 1
1920x1080 (0x22) 173.250MHz -HSync +VSync *current +preferred
h: width 1920 start 2048 end 2248 total 2576 skew 0 clock 67.26KHz
v: height 1080 start 1083 end 1088 total 1120 clock 60.05Hz
XWAYLAND1 connected 1920x1080+1920+0 (0x3a9) normal (normal left inverted right x axis y axis) 480mm x 270mm
Identifier: 0x3a8
Timestamp: 47805
Subpixel: unknown
Gamma: 1.0:1.0:1.0
Brightness: 0.0
Clones:
CRTC: 1
CRTCs: 1
Transform: 1.000000 0.000000 0.000000
0.000000 1.000000 0.000000
0.000000 0.000000 1.000000
filter:
non-desktop: 0
supported: 0, 1
1920x1080 (0x3a9) 173.000MHz -HSync +VSync *current +preferred
h: width 1920 start 2048 end 2248 total 2576 skew 0 clock 67.16KHz
v: height 1080 start 1083 end 1088 total 1120 clock 59.96Hz

Ok, it’s really a wayland session. GDM sometimes does this. Please try this:
https://askubuntu.com/questions/975094/how-to-disable-wayland-in-17-10-in-gdm3-login-screen

After editing the file …/custom.conf, the graphical interface doesn’t start.

Please create a ne nvidia-bug-report.log in that state.
If you have internet connection, you can use pastebinit to upload it from console.

  • install pastebinit
  • unzip logfile (gunzip nvidia-bug-report.log.gz)
  • upload logfile (pastebinit -i nvidia-bug-report.log)
  • note down and post the url you’re given

I’ll wait for the weekend to perform the test. I need the laptop to work… at least until friday … hahaha
Thanks for the support!