RadHat8 : Nvidia-settings do not shows any x-server configuration

Hi there,
I am using HP Omen with I7 running with GEForce RTX-3060.
I have installed nvidia/510.60.02 and here is

[pradeep@192 ~]$ dkms status
nvidia/510.60.02, 4.18.0-348.20.1.el8_5.x86_64, x86_64: installed

however nvidia-settings - shows below errors:

ERROR: NVIDIA driver is not loaded

(nvidia-settings:3968): GLib-GObject-CRITICAL **: 00:59:57.148: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:3968): CRITICAL **: 00:59:57.149: ctk_powermode_new: assertion '(ctrl_target != NULL) && (ctrl_target->h != NULL)' failed

I am attaching bug report - alongwith

  • I have tried running laptop with disabling secure mode → but it stuck at start up with logo.
  • I even tried putting ‘AllowEmptyInitialConfiguration’ in xorg.conf
  • also prime-select command is not found
  • and nvidia-rmi says NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running. even though I downloaded it after searching the correct driver version.
  • My driver installation was successful.
    nvidia-bug-report.log.gz (89.3 KB)

I have been trying this since past many weeks but seeing no success, any help will be deeply appreciated.


Please disable secure boot in bios.

I did so then it do not show me login, instead just a manufacturer logo and stayed there, I did wait there for 5-10 minutes but nothing changes.

Please delete /etc/X11/xorg.conf since you have a hybrid graphics notebook, the internal display is driven by the intel gpu.

I removed the xorg.conf then I disabled the secure boot; same no change.

Note: On disabling the secure boot → I could not login, as it again hang on startup. I had to revert it.

Please create a new nvidia-bug-report.log with secure boot disabled and xorg.conf deleted.

nvidia-bug-report.log.gz (83.1 KB)
Attached bug report with secure-boot disabled and xorg.conf delete.

Note: I had to create bug report with with nonGUI (i.e. systemctl set-default multi-user.target). because on disabling secure-boot I could not reach desktop.

Secure boot was still enabled:

[ 0.000000] secureboot: Secure boot enabled

1 Like

Meneer, I don’t know what happened.
But, this time I again disabled the secure boot and tried again and unbelievable I saw login screen and along with I can see what I wanted to see since weeks.
Finally this appears an Easter miracle. Many thanks …