(nvidia-settings:11824): GLib-GObject-CRITICAL **: 20:31:17.027: g_object_unref: assertion 'G_IS_OBJECT (object)' failed


I’m trying to setup Asus GTX 1050 Ti Nvidia Egpu on Acer Aspire E5-575 laptop (OS:Pop OS 22.04, Core I5, Memory 16 GB)

After installed latest Nvidia driver (510) when I run $nvidia-settings its throwing below error messages.
Also xserver not showing any configuration.


ERROR: A supplied argument is invalid

(nvidia-settings:11824): GLib-GObject-CRITICAL **: 20:31:17.027: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

** (nvidia-settings:11824): CRITICAL **: 20:31:17.029: ctk_powermode_new: assertion ‘(ctrl_target != NULL) && (ctrl_target->h != NULL)’ failed

ERROR: nvidia-settings could not find the registry key file or the X server is not accessible. This
file should have been installed along with this driver at
/usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will
continue to work, but values cannot be prepopulated or validated, and will not be listed in
the help text. Please see the README for possible values and descriptions.

** (nvidia-settings:11824): WARNING **: 20:31:17.067: PRIME: Failed to execute child process “/usr/bin/prime-supported” (No such file or directory)
** Message: 20:31:17.067: PRIME: is it supported? no
nvidia-bug-report.log.gz.gz (177.0 KB)

Note: Secure boot disabled from bios

Hi @pritamfreedom ,

My first guess would be that you have a driver version conflict. If you look at the log you provided, you see that the system tries to load three different kernel modules for the GPU (I just included three samples from different timestamps below):

pop-os kernel: [    4.942497] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  390.147
pop-os kernel: [    5.499639] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  470.86
pop-os kernel: [  779.816541] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  510.68.02

The first thing you should try would be to make a clean re-install of the latest driver. Purge all traces of the old drivers and start a fresh install.


/usr/bin/nvidia-smi --query

No devices were found

is a good indication that the driver installation was not successful.

Since Pop OS is (roughly) based on Ubuntu, maybe it is possible to use the latest Ubuntu certified driver for installation through the integrated package manager? I am not that familiar with Pop OS, so please see this simply as a suggestion.

After purge all Nvidia drivers , I’ve freshly installed new recommended driver 510.68.02. But same error appears. sending you the attachment of Nvidia bug report.

Gpu Manager Output

…# sudo gpu-manager
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can’t access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/5.17.5-76051705-generic/kernel
Looking for nvidia modules in /lib/modules/5.17.5-76051705-generic/updates/dkms
Looking for amdgpu modules in /lib/modules/5.17.5-76051705-generic/kernel
Looking for amdgpu modules in /lib/modules/5.17.5-76051705-generic/updates/dkms
Is nvidia loaded? yes
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? yes
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is nvidia kernel module available? no
Is amdgpu kernel module available? no
Vendor/Device Id: 8086:5916
BusID “PCI:0@0:2:0”
Is boot vga? yes
Vendor/Device Id: 10de:1c82
BusID “PCI:1@0:0:0”
Is boot vga? no
Chassis type: “10”
Laptop detected
can’t access /etc/u-d-c-nvidia-runtimepm-override file
Found json file: /usr/share/doc/nvidia-driver-510-server/supported-gpus.json
File /usr/share/doc/nvidia-driver-510-server/supported-gpus.json not found
Is nvidia runtime pm supported for “0x1c82”? no
Checking power status in /proc/driver/nvidia/gpus/0000:01:00.0/power
Runtime D3 status: ?
Is nvidia runtime pm enabled for “0x1c82”? no
Skipping “/dev/dri/card0”, driven by “i915”
Skipping “/dev/dri/card0”, driven by “i915”
Skipping “/dev/dri/card0”, driven by “i915”
Found “/dev/dri/card0”, driven by “i915”
output 0:
Number of connected outputs for /dev/dri/card0: 1
Does it require offloading? yes
last cards number = 2
Has amd? no
Has intel? yes
Has nvidia? yes
How many cards? 2
Has the system changed? No
Takes 0ms to wait for nvidia udev rules completed.
Intel IGP detected
NVIDIA hybrid system

nvidia-bug-report-15th-May-2022.log.gz (210.3 KB)