What should i do i can't start the video card

Friends, although I have installed the direvers of my display card (1050 ti laptop), my video card is not used. I tried to set it to prime first but it didn’t work. Then, in a foreign forum, they said that this happens in systems that are not set up as UEFI, I went and converted the system to UEFI, and it still did not work. When I run the nvidia-smi command, I get the answer no device, when I go to the graphics card settings in obs, it gives an error message and says to do the updates. I made the updates, nvidia-510 is installed now (I tried other drivers as it might be a driver error). Also, when I call nvidia-setting, I get the error code I left at the bottom. After the error code, the application still opens. I followed the discrete path in the BIOS. I can’t think of anything else now, and I couldn’t find anything on the other forums either. Thank you in advance for your help.
ERROR: A supplied argument is invalid

(nvidia-settings:2990): GLib-GObject-CRITICAL **: 22:03:31.555: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

** (nvidia-settings:2990): CRITICAL **: 22:03:31.556: ctk_powermode_new: assertion ‘(ctrl_target != NULL) && (ctrl_target->h != NULL)’ failed

ERROR: nvidia-settings could not find the registry key file or the X server is not accessible. This file should have been installed along
with this driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will continue to work,
but values cannot be prepopulated or validated, and will not be listed in the help text. Please see the README for possible values and

Hi @domer1581 .

I recommend you take a look at an older thread: RTX 2060 GPU not recognized by Linux

Especially the part about purging older drivers and installing for secure boot (UEFI) systems.

Depending on which distribution you are using there will be instructions on how to authenticate the NVIDIA driver so it will be correctly installed to support secure boot.

Alternatively you can disable secure boot again and then do a clean re-install.

I hope this helps!