ERROR: Unable to load the 'nvidia-drm' kernel module - CentOS 7 x86_64, version 410.78

I recently updated the kernel from 3.10.693 to 4.14.15 and found the driver didn’t work any more, i tried to reinstall the driver, and found the error on the title. I’ve found a similar topic here https://devtalk.nvidia.com/default/topic/1048189/linux/error-unable-to-load-the-nvidia-drm-kernel-module-centos-7-x86_64-version-396-54/, but I’m quite sure that the nouveau has been disabled, and my X server couldn’t start. Here is what I collected:

startx -- -logverbose 6
xauth:  file /root/.serverauth.18126 does not exist


X.Org X Server 1.19.3
Release Date: 2017-03-15
X Protocol Version 11, Revision 0
Build Operating System:  3.10.0-693.2.2.el7.x86_64 
Current Operating System: Linux i9 4.14.15-1.el7.elrepo.x86_64 #1 SMP Tue Jan 23 20:28:26 EST 2018 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-4.14.15-1.el7.elrepo.x86_64 root=/dev/mapper/centos-root ro crashkernel=auto rd.lvm.lv=centos/root rd.lvm.lv=centos/swap rhgb quiet LANG=en_US.UTF-8
Build Date: 25 January 2018  04:04:44PM
Build ID: xorg-x11-server 1.19.3-11.el7_4.1 
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar 19 10:14:50 2019
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

nvidia-bug-report.log.gz (78.6 KB)
nvidia-installer.log (8.73 KB)

[  155.965490] nvidia: version magic '4.14.15-1.el7.elrepo.x86_64 SMP mod_unload modversions retpoline ' should be '4.14.15-1.el7.elrepo.x86_64 SMP mod_unload modversions '

Your kernel is compiled without retpoline support.

Hi, generix
thanks for pointing out the mistake, but I was wondering if there is a retpoline patch that I could use to fix this problem. my kernel was installed through rpm file. If there is not a patch, should I compile the kernel manually? I am not quite familiar with this area, any help would be very nice.
below is some check I’ve made:

cat /sys/devices/system/cpu/vulnerabilities/spectre_v2
Vulnerable: Minimal generic ASM retpoline
grep "RETPO\|PAGE_TABLE" /boot/config-4.14.15-1.el7.elrepo.x86_64
CONFIG_RETPOLINE=y
CONFIG_PAGE_TABLE_ISOLATION=y

but when I check this file, it seems that retpoline is enabled, could it be the mismatch between config and actual kernel?

Looks like a known problem, follow this:
https://support.huawei.com/enterprise/de/doc/EDOC1100027231/d71af05b/compiling-the-ibma-driver-linux-os

many thanks, follow this i’ve solved my problem.