Error when install Jetson Software with SDK Manager

Hi,
I’m tying to install Jetson Software using SDK manger on Jetson AGX Xavier.
Error occurs when “Flash” step after downloading completed.

Please, let me know what is the problem.

Log message as follow :

2019-03-22 16:54:29.242 - info: Found route default wlx0026660177e8, setting up device mode
2019-03-22 16:54:29.337 - info: net.ipv4.ip_forward = 1
2019-03-22 16:54:44.559 - info: Default google DNS is not working, trying to find a valid server in local host settings!
2019-03-22 16:54:44.831 - info: Device mode on host successfuly set with DNS 165.156.22.1!
2019-03-22 16:54:44.896 - info: [ Component Install Finished Successfully ]
2019-03-22 16:54:44.896 - info: [ 12.00 KB used. Disk Avail: 410.37 GB ]
2019-03-22 16:54:44.897 - info: [ NV_L4T_DEVICE_MODE_SETUP_COMP_IN_FLASH Install took 16s ]
2019-03-22 16:54:44.897 - info: cmd finished success SDKM_END_CODE_SUCCESS_af6b86da-7885-475b-baeb-6510cfb179ed
2019-03-22 16:54:44.897 - info: command finished successfully
2019-03-22 16:54:44.943 - info: install ‘Device Mode Host Setup in Flash’ success
2019-03-22 16:54:45.076 - info: Start to install ‘Flash Jetson AGX Xavier’
2019-03-22 16:54:45.077 - info: estimated install timeout for NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP: 3600s
2019-03-22 16:54:45.175 - info: [ Disk Avail:410.37 GB ]
2019-03-22 16:54:45.175 - info: Using GenericInstaller to Install NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP
2019-03-22 16:54:45.175 - info: enter working directory: /home/geuk_dl/nvidia/nvidia_sdk/JetPack_4.2_Linux_P2888/Linux_for_Tegra
2019-03-22 16:54:45.175 - info: [ Component Install Started ]
2019-03-22 16:54:45.175 - info: current working directory is /home/geuk_dl/nvidia/nvidia_sdk/JetPack_4.2_Linux_P2888/Linux_for_Tegra
2019-03-22 16:54:45.175 - info: exec_command [target]:
2019-03-22 16:54:45.175 - info: **********************
2019-03-22 16:54:45.175 - info: #!/bin/bash
2019-03-22 16:54:45.175 - info: set -e
2019-03-22 16:54:45.176 - info: export LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 LANGUAGE=en_US.UTF-8
2019-03-22 16:54:45.176 - info: sudo reboot forced-recovery
2019-03-22 16:54:45.176 - info: **********************
2019-03-22 16:54:45.176 - info: exec_command: scp -q -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no /tmp/tmp_NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP.sh nvidia@192.168.55.1:~; ssh -t -q -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no nvidia@192.168.55.1 “~/tmp_NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP.sh && rm -f ~/tmp_NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP.sh”
2019-03-22 16:56:55.073 - error: lost connection
2019-03-22 16:59:06.146 - info: exit status 255
2019-03-22 16:59:06.147 - warn: command scp -q -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no /tmp/tmp_NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP.sh nvidia@192.168.55.1:~; ssh -t -q -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no nvidia@192.168.55.1 “~/tmp_NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP.sh && rm -f ~/tmp_NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP.sh” finished with error, but ignored
2019-03-22 16:59:06.515 - info: exec_command: sleep 20
2019-03-22 16:59:26.226 - info: exec_command: sudo ./flash.sh jetson-xavier mmcblk0p1
2019-03-22 16:59:26.594 - info: ###############################################################################
2019-03-22 16:59:26.595 - info: # L4T BSP Information:
2019-03-22 16:59:26.595 - info: # R32 (release), REVISION: 1.0, GCID: 14531094, BOARD: t186ref, EABI: aarch64,
2019-03-22 16:59:26.595 - info: # DATE: Wed Mar 13 07:41:08 UTC 2019
2019-03-22 16:59:26.595 - info: ###############################################################################
2019-03-22 16:59:26.595 - info: # Target Board Information:
2019-03-22 16:59:26.599 - info: # Name: jetson-xavier, Board Family: t186ref, SoC: Tegra 194,
2019-03-22 16:59:26.599 - info: # OpMode: production, Boot Authentication: NS,
2019-03-22 16:59:26.600 - info: ###############################################################################
2019-03-22 16:59:26.600 - info: copying soft_fuses(/home/geuk_dl/nvidia/nvidia_sdk/JetPack_4.2_Linux_P2888/Linux_for_Tegra/bootloader/t186ref/BCT/tegra194-mb1-soft-fuses-l4t.cfg)… done.
2019-03-22 16:59:26.600 - info: ./tegraflash.py --chip 0x19 --applet “/home/geuk_dl/nvidia/nvidia_sdk/JetPack_4.2_Linux_P2888/Linux_for_Tegra/bootloader/mb1_t194_prod.bin” --skipuid --soft_fuses tegra194-mb1-soft-fuses-l4t.cfg --bins “mb2_applet nvtboot_applet_t194.bin” --cmd “dump eeprom boardinfo cvm.bin;reboot recovery”
2019-03-22 16:59:26.600 - error: /usr/bin/env: ?쁯ython??
2019-03-22 16:59:26.600 - error: : No such file or directory
2019-03-22 16:59:26.600 - info: Reading board information failed.
2019-03-22 16:59:26.600 - info: exit status 1
2019-03-22 16:59:26.602 - info: [ Component Install Finished with Error ]
2019-03-22 16:59:26.602 - error: NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP command sudo ./flash.sh jetson-xavier mmcblk0p1 finished with error
2019-03-22 16:59:26.602 - info:
2019-03-22 16:59:26.602 - info: [ 8.00 KB used. Disk Avail: 410.37 GB ]
2019-03-22 16:59:26.603 - info: [ NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP Install took 4m41s ]
2019-03-22 16:59:26.603 - info: command sudo ./flash.sh jetson-xavier mmcblk0p1 finished with error
2019-03-22 16:59:26.603 - info: cmd finished failure SDKM_END_CODE_FAILURE_feccb991-5fbd-47d1-9113-ed6bdf0d34fe
2019-03-22 16:59:26.603 - error: command terminated with error
2019-03-22 16:59:26.953 - error: install ‘Flash Jetson AGX Xavier’ failure, command < cd ‘/home/geuk_dl/nvidia/nvidia_sdk/JetPack_4.2_Linux_P2888’ ; /opt/nvidia/sdkmanager/resources/app/output/installUtils/adapter -a=‘install’ -c=‘eyJpZCI6Ik5WX0w0VF9GTEFTSF9YQVZJRVJfV0lUSF9PU19JTUFHRV9DT01QIiwibmFtZSI6IkZsYXNoIEpldHNvbiBBR1ggWGF2aWVyIiwiZGVzY3JpcHRpb24iOiJGbGFzaCBKZXRzb24gQUdYIiwiY29tcFR5cGUiOiJmbGFzaCIsImlzVmlzaWJsZSI6dHJ1ZSwibGljZW5zZUlkIjoiTlZfSkVUUEFDS19PU19FVUxBIiwiaXNEZXRlY3RhYmxlSW5zdGFsbCI6ZmFsc2UsImlzSW5zdGFsbFBhdGhDdXN0b21pemFibGUiOnRydWUsInRpbWVvdXRTZWNvbmRzIjozNjAwLCJ2ZXJzaW9uIjoiMzIuMSIsIm9wZXJhdGluZ1N5c3RlbXMiOlsidWJ1bnR1MTYwNCIsInVidW50dTE4MDQiXSwiaW5zdGFsbFNpemVNQiI6MzAwNTMsImRvd25sb2FkRmlsZXMiOltdLCJpbnN0YWxsUGFyYW1ldGVycyI6eyJpbnN0YWxsRGlyIjoie3tUQVJHRVRfUk9PVH19L3t7QlVORExFX1RJVExFfX1fe3tCT0FSRF9JRH19L0xpbnV4X2Zvcl9UZWdyYSIsImluc3RhbGxDb21tYW5kcyI6W3sicmVtb3RlRXhlY0Jhc2giOlsic3VkbyByZWJvb3QgZm9yY2VkLXJlY292ZXJ5Il0sImlnbm9yZUVycm9yIjp0cnVlfSx7ImNvbW1lbnQiOiJ3YWl0IGZvciBkZXZpY2UgdG8gc2h1dGRvd24gYW5kIHRvIGdvIHRvIHJlY292ZXJ5IG1vZGUiLCJ1c2VyQ29tbWFuZCI6InNsZWVwIDIwIn0seyJ1c2VyQ29tbWFuZCI6InN1ZG8gLi9mbGFzaC5zaCBqZXRzb24teGF2aWVyIG1tY2JsazBwMSJ9LHsidXNlckNvbW1hbmQiOiJzbGVlcCAxMCJ9XX0sInRhcmdldElkcyI6WyJQMjg4OCJdLCJkZXBlbmRlbmNpZXMiOlt7ImlkIjoiTlZfTDRUX0ZJTEVfU1lTVEVNX0FORF9PU19YQVZJRVJfQ09NUCIsIm9wZXJhdG9yIjoiPT0iLCJ2ZXIiOiIzMi4xIn0seyJpZCI6Ik5WX0w0VF9EUklWRVJTX1hBVklFUl9DT01QIiwib3BlcmF0b3IiOiI9PSIsInZlciI6IjMyLjEifSx7ImlkIjoiTlZfTDRUX0RFVklDRV9NT0RFX1NFVFVQX0NPTVBfSU5fRkxBU0giLCJvcGVyYXRvciI6Ij09IiwidmVyIjoiMS4wIn1dLCJleHRlcm5hbF9kZXBlbmRlbmNpZXMiOltdLCJwYXJlbnRJRCI6Ik5WX0RSSVZFX0ZMQVNIX1RBUkdFVF9HUk9VUCIsImFjdGlvbiI6MSwiaW5zdGFsbFBhdGgiOiIvaG9tZS9nZXVrX2RsL252aWRpYS9udmlkaWFfc2RrL0pldFBhY2tfNC4yX0xpbnV4X1AyODg4IiwiZG93bmxvYWRFcnJvcnMiOltdLCJidW5kbGVUaXRsZSI6IkpldFBhY2tfNC4yX0xpbnV4IiwiaW5zdGFsbFJvb3QiOiIvaG9tZS9nZXVrX2RsL252aWRpYS9udmlkaWFfc2RrIiwiYm9hcmRJRCI6IlAyODg4IiwidGFyZ2V0QWNjZXNzSW5mbyI6eyJ1c2VyIjoibnZpZGlhIiwicGFzc3dvcmQiOiJudmlkaWEiLCJob3N0IjoiMTkyLjE2OC41NS4xIiwicG9ydCI6IjIyIn19’ -i=‘NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP’ -v=‘32.1’ -l=’/home/geuk_dl/nvidia/nvidia_sdk/JetPack_4.2_Linux_P2888’ -L=’/home/geuk_dl/.nvsdkm/logs/JetPack_4.2_Linux’ -p=‘4547’ -t=‘P2888’ -e=‘undefined’ > terminated with error

My installer is failing at this exact point as well.

To clarify, my host is running Ubutnu 18.04.2 LTS on a standalone laptop (not a VM). The host is newly set up (completely fresh OS install). Since installing the OS, I’ve:

  1. downloaded ‘sdkmanager_0.9.11-3405_amd64.db’
  2. Installed the sdk manager: sudo apt install ~/Downloads/sdkmanager_0.9.11-3405_amd65.deb
  3. Plugged the Jetson Xavier up in this order: HDMI, keyboard/mouse usb dongle, Ethernet, power - then pressed/hold ‘recovery’ button, pressed/hold ‘power’ button, released both (power light turns on)
  4. Run the SDK Manager, which was successful up until the above error during the ‘Flash Jetson OS’ step

Interestingly enough, if I power down the Jetson device, and power back on, I successfully boot into a shell on the device itself, ie. “nvidia@localhost:~$_”, which verifies that the device OS was flashed - but with the SDK failure I am sure not everything was set up correctly.

Running ip ad on the Jetson device shows that my Ethernet interface is DOWN (eth0), and I am unable to ping anything on my local network from the Jetson device.

I have verified that the Ethernet port on my device is physically connected to my network (the light on my switch shows that it is connected), but the Jetson Xavier device never shows up on my router (indicating that while physically connected, the Jetson device never sets up its interface correctly - likely because it fails before it gets to this point).

Just as a further detail, not sure if it matters, but my host laptop is connected to the same network at the Jetson Xavier device, but using wifi.
ie. using the following network between host/device:

[Jetson Xavier] <- Ethernet -> [Switch] <- Ethernet -> [Router/Gateway] <- Wifi -> [Host Ubuntu Laptop]

I have verified that I can see the Jetson device from my host - running lsusb -d 955:7019 successfully shows my Jetson Xavier is connected (I have the USB-C connector on the front of the device attached to a USB-A port on my host).

So yes, any help on the OP’s issue will help me as well. Thank you!

I was having the same problem. It seems that NVIDIA forget to mention that their scripts uses python.

In yout post check these lines

2019-03-22 16:59:26.600 - error: /usr/bin/env: ?쁯ython??
2019-03-22 16:59:26.600 - error: : No such file or directory

it requires python command, but Ubuntu 18.04 install python3 command as default.

Install python: sudo apt-get install python

check if the python command works, and exit().

And NVIDIA SDK should work from that point.

I wasted like a week with that problem.Shame on the person that makes the NVIDIA documentation. You need to look very close to what they use in their scripts. I follow line by line until I found that python command.

Cheers

1 Like

It worked! Yes, shame indeed. I’ll post my complete [WORKING] steps below for OP (any anyone else who is looking to get the board set up out of the box).

So for the record, this was my official install process for getting the Jetson AGX Xavier board up and running:

  1. Install Ubuntu 18.04.2 LTS (64-bit) onto an empty intel i7 laptop
    * this is the “host” machine
  2. Log into the host machine and browse to the NVidia website
    * https://developer.nvidia.com/embedded/downloads
  3. Download the NVIDIA SDK MANAGER software
    * https://developer.nvidia.com/embedded/dlc/nv-sdk-manager
  4. Install the NVIDIA SDK MANAGER
    > sudo apt install ./sdkmanager_0.9.11-3405_amd64.deb
  5. Install Python 2.7 (this is the step I missed in this thread, probably same for OP)
    > sudo apt install python
  6. Plug in HDMI, Mouse/Keyboard, Ethernet, Power into the Jetson Xavier device
  7. Power the Jetson Xavier device into recovery mode by press/hold recovery button, then press/hold power. then release
  8. Verify the Jetson Xavier device shows up on host
    > lsusb -d 0955:7019
  9. Open NVIDIA SDK MANAGER and follow the prompts
    * I used “automatic” install to create a user/password
  10. On the Jetson Xavier device, follow the Ubuntu prompts to set up the device
    * These prompts will show up on the monitor connected via HDMI to the Jetson Xavier
  11. Once the device’s Ubuntu setup is complete, setup will restart the device
  12. After the device has restarted, switch back to the host and follow the prompts in the running NVIDIA SDK MANAGER software to complete package installation (ie. flash CUDA, AI, etc. on the Jetson device)
1 Like

Hi BitReiver,

Have you installed the “Computer Vision” successfully without “downgrade” some packages on target?

I flashed OS Image, finished the Ubuntu installation successfully (maybe because python was installed before). However, when I tried to finish the “SDK components” with the SDK Manager, it failed during the “Computer Vision” part. Manually run the script on the target, I found some conflictions and solved them by downgrading some packages with “aptitude install”.

I also encountered similar problems when installing ROS.

Install the following packages:
1)      libmysqlclient-dev [5.7.21-1ubuntu1 (bionic)]

      Downgrade the following packages:
2)      libcairo-gobject2 [1.15.10-2ubuntu0.1 (now) -> 1.15.10-2 (bionic)]
3)      libcairo2 [1.15.10-2ubuntu0.1 (now) -> 1.15.10-2 (bionic)]
4)      libldap-2.4-2 [2.4.45+dfsg-1ubuntu1.1 (now) -> 2.4.45+dfsg-1ubuntu1 (bionic)]
5)      libmysqlclient20 [5.7.25-0ubuntu0.18.04.2 (now) -> 5.7.21-1ubuntu1 (bionic)]
6)      libpoppler-glib8 [0.62.0-2ubuntu2.7 (now) -> 0.62.0-2ubuntu2.2 (bionic-security, bionic-updates)]
7)      libpoppler73 [0.62.0-2ubuntu2.7 (now) -> 0.62.0-2ubuntu2.2 (bionic-security, bionic-updates)]
8)      libpython3-stdlib [3.6.7-1~18.04 (now) -> 3.6.5-3ubuntu1 (bionic-updates)]
9)      libpython3.6 [3.6.7-1~18.04 (now) -> 3.6.6-1~18.04 (bionic-updates)]
10)     libpython3.6-minimal [3.6.7-1~18.04 (now) -> 3.6.6-1~18.04 (bionic-updates)]
11)     libpython3.6-stdlib [3.6.7-1~18.04 (now) -> 3.6.6-1~18.04 (bionic-updates)]
12)     libssl1.1 [1.1.0g-2ubuntu4.3 (now) -> 1.1.0g-2ubuntu4.1 (bionic-security, bionic-updates)]
13)     libtiff5 [4.0.9-5ubuntu0.1 (now) -> 4.0.9-5 (bionic)]
14)     libzmq5 [4.2.5-1ubuntu0.1 (now) -> 4.2.5-1 (bionic)]
15)     poppler-utils [0.62.0-2ubuntu2.7 (now) -> 0.62.0-2ubuntu2.2 (bionic-security, bionic-updates)]
16)     python3 [3.6.7-1~18.04 (now) -> 3.6.5-3ubuntu1 (bionic-updates)]
17)     python3-distutils [3.6.7-1~18.04 (now) -> 3.6.5-3 (bionic)]
18)     python3-lib2to3 [3.6.7-1~18.04 (now) -> 3.6.5-3 (bionic)]
19)     python3-minimal [3.6.7-1~18.04 (now) -> 3.6.5-3ubuntu1 (bionic-updates)]
20)     python3.6 [3.6.7-1~18.04 (now) -> 3.6.6-1~18.04 (bionic-updates)]
21)     python3.6-minimal [3.6.7-1~18.04 (now) -> 3.6.6-1~18.04 (bionic-updates)]

Not sure if it’s the right way to solve these dependency problems. Or I missed something important.

No, I’m sorry I did not see those errors when I installed. All of the remaining software packages in the SDK Manager installed without issue. I have not, however, installed ROS.

Thanks a lot. Problem solved.

I too am having similar issues. I was able to get the OS installed after downgrading python3 to python2.

Now, it is failing on the SDK components, CUDA step with:

Err:5 http://ports.ubumtu.com/unbuntu-ports bionic InRelease
Could not resolve ‘ports.ubuntu.com

I have this configuration:
[Jetson Xavier] <- Ethernet -> [Switch] <- Ethernet -> [ubuntu on Dell laptop] <- Wifi -> [Internet]

Looking at ports.ubuntu.com, I found InRelease (and Release) at http://ports.ubuntu.com/unbuntu-ports/bionic

Any help?
Best Regards

Seems the DNS on your Jetson device doesn’t work.
Can you check if the switch is assigning DNS settings to your Jetson device?

I see two typographic errors. What you posted:

http://ports.ubu<b><u><i>m</i></u></b>tu.com/u<b><s>n</s></b>buntu-ports

Try it with the “m” back to “n”, and the extra “n” removed:
http://ports.ubuntu.com/ubuntu-ports

Have your repository files been edited?