ESXi 6.7 + Tesla V100 + 430.27 + passthrough not working

I want to passthrough the GPU to one single VM. But the VM does not starts with the Error:

Module ‘DevicePowerOn’ failed.

I configured it like in the nvidia documentation:
https://docs.nvidia.com/grid/5.0/grid-vgpu-user-guide/index.html#using-gpu-pass-through-vmware-vsphere

the vt-d and the passthrough in ESXi host is active:
https://docs.vmware.com/en/VMware-Horizon-7/7.5/horizon-virtual-desktops/GUID-41547581-2CAC-40D2-AC9F-962E8D649B5E.html

vt-d is 3, it means it is enabled (https://kb.vmware.com/s/article/1011712)

[root@bigdata:~] esxcfg-info | grep "HV Support"
         |----HV Support............................................3
ResourceGroup: Skipping CPU times for: Vcpu Id 2104401 Times due to error: max # of processors: 12 < 2104401
ResourceGroup: Skipping VCPU stats for: Vcpu Id 2104401 Times due to error: max # of processors: 12 < 2104401
ResourceGroup: Skipping CPU times for: Vcpu Id 2104403 Times due to error: max # of processors: 12 < 2104403

passthrough is enabled:

VM settings, all memory is reserved, instead normal bios is efi:

i try some solution from the internet like set the svga.present=FALSE in VM-Options-Advanced, but the error message still there

Hi hsler!

I am exactly in the same situation as you (yeah, let’s cry together), also with a V100 (16GB) and the same error: “Module ‘DevicePowerOn’ power on failed”

I have a couple of questions:

  • Did you get any solution for the problem so far?
  • Are you using a cloud provider or the server is in your premises? (I am starting to think that this could be related to something not properly activated in the BIOS).

Best,
Pablo

I found the solution, just in case you’re still with this: https://communities.vmware.com/thread/619635

I would guess it is related to the amount of assigned system memory.
Check our product documentation with known limitations and enable the following key:
pciPassthru0.cfg.enable_large_sys_mem