Tesla P40 in VMWare ESXI 6.7 is not working in passthrough mode for created VM's - DELL R730

Setup Details :

  • GPU Card - Tesla P40

  • VMWare ESXI - 6.7

  • Server - Dell PowerEdge R730

  • CPU

  • Memory

  • Issue : After installing and configuring the ESXI and VCenter in the Dell server with Tesla P40 GPU card I am not able to start any created VM attached with GPU as PCI in passthrough mode.

Below is the Vcenter settings for graphics for GPU passthrough,

Below is the VM Setting with the added GPU (passthrough) as PCI device,

After applying the setting when I try to start the VM it doesnot start and pops up an error as follows,


Operation Failed : Device poweron failed.

But when I tried starting the VM after removing the GPU it boots up normally.

Can anyone please help on this issue.?

There are some settings you need to do for passthrough of GPU in ESXi. Please review your settings as per this link: Using GPUs with Virtual Machines on vSphere - Part 2: VMDirectPath I/O - Virtualize Applications

The VM needs to boot in EFI mode, and you need to also set the pciPassthru.use64bitMMIO=”TRUE” and pciPassthru.64bitMMIOSizeGB= (In the case of P40, 64 should do).

Does anybody noticed problems with max resolution used in a windows10 Pro VM using a P40 in Passthrough mode? I’m trying to access using VNC or Teradici and I can only set it to 1440x900 max resolution. In shared mode using part of a P40 as a vGPU I can use 3840x2160 (as native) resolution without any problem.

How can I increase the max resolution supported for a TERA DEFAULT monitor when using the P40 in passthrough mode?

Thank you in advance,
Òscar Calaf

Hi,
not aware of any resolution issues with P40 in PT. You could try to fake the EDID file to get your desired 4k resolution.

regards
Simon