Failed to start NVIDIA-persistence daemon & Black Screen on JETSON Nano

Hello, I am currently working on a NVIDIA Jetson Nano. I shuted it down last friday but when I came back on monday I had the following error message “[FAILED] Failed to start NVIDIA Persistence Daemon” when booting the Jetson Nano followed by a black screen. If someone could help that would be nice!

You’ll need to post a full serial console boot log to see what comes before that point. See:

It would also be good to describe if your monitor is HDMI, or if it has any kind of adapter.

There is a chance you’ll need to reflash either the QSPI memory of the module or the SD card (I’m assuming this is a dev kit; if this is something different with eMMC, then you’ll want to describe that). If you have valuable data, then you might consider cloning the SD card on a Linux host PC before any kind of flash. With serial console it might be possible to find a solution without flash, but flash is a possibility.

1 Like

My monito is HDMI, I will try reflashing my SD card, that is what I was planning to do anyway. I will tell you if it worked properly once it’s done. Thank you very much for the help, have a nice day mate.

Thought I haven’t tried reflashing I have another question, when I try ctrl+alt+f6 shortcut the console appear for 1second and then the booting screen with the following line at the end: "Late Init Script [OK] Reached target Graphical Interface. Starting Updtate UTMP about System Runlevel Changes. Reached target multi-user System[OK] Started NVIDIA. "
And then it’s back to black screen, I am really confused…

UPDATE, I could go to the console without any black screen to interupt. My system got minimize, when I try unminimizing it I have the following error:

unminimize is not what you think it is. This is just documentation from man pages. You shouldn’t unminimize unless you have a lot of disk space available.

Note that multi-user ( is the runlevel for text-mode login. graphical ( is the GUI. Each has different requirements. It is possible that one works and the other does not due to configuration. It is useful to know it said it reached those states, but it isn’t enough. You need a serial console boot log. The serial console has no dependency on graphics, and it has no dependency on networking. Much of the system can crash and burn and serial console will survive. Stages prior to Linux can also produce serial console logging, and obviously Linux itself has no record of what came before it started. So take a look at the serial console URL I gave and try to get a full boot log. Your host PC can run a serial console log starting right before you power up the Jetson, and the host PC will capture a log file for the entire boot which you can attach to the forum.

Incidentally, although ssh is not as good for this as serial console, if ssh exists, it can be useful. Typically, Wi-Fi is tied to a user logging in to the GUI (which I hate and I avoid Wi-Fi), but if you have ssh access through wired networking (either the actual ethernet, or having the correct USB cable between Jetson and host PC), then that could be quite useful to log in to the Jetson and poke around some.

Also, the SD card is not everything. There is QSPI memory on the Jetson module itself for SD card models, and this contains boot and other content, which can be flashed separately and is not the o/s itself.

i flashed my SD card using Etcher and my Jetson Nano fails to boot. It hangs at:

A start job is running for End-user configuration after initial OEM installation (XXmin XXs / no limit)

The flash does not put your user name and password in, it waits until the first boot (old story trivia: This is due to California laws against the default name/pass which used to be used). You need to set up the user name and password.

Normally you would be able to do this on the monitor. However, you can also use serial console for this under some circumstances. Do you see an opportunity to enter name and password setup either on the monitor or via serial console?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.