Jetson nano failed to show NVIDIA screen on startup

We are facing unexpected multiple reboot on jetson nano dev. kit. After which it suddenly stopped showing NVIDIA Screen on startup.

HW connected:
camera, LTE board & audio card over USB which are powered externally.
SPI to can converter module
dev. kit is powered from DC jack from 5v, 5A power supply
Original heat sink is replaced with heat sink with PWM fan
Screen connected over HDMI

GPU usage:
one AI model runs on GPU

Next day, it started working and we could retrieve syslog and kernel log. From the syslog, we have observed that some reboot is because of “gk20a_fifo_handle_mmu_fault_locked:1721 [ERR]”. (Kernel Log attached for reference)

After which we kept for overnight testing and again next day system was in hang state.

We removed all connected interfaces and try to power up the jetson nano dev kit but issue still persists.

Please help to resolve this issue.
kern.log (823.2 KB)

Please just share me the log during the time the hang happened.

Hi Wayne,

Thanks for reply.

Please find attached kernel log of last reboot after which Jetson nano goes to hang state.
system_hang.log (87.9 KB)

I don’t see any useful log from dmesg. Please dump the log from uart.

Hi Wayne,

Since yesterday, we are trying to regenerate issue, but we are still not successful to capture console log for hang state.

We captured the console log for working state in which we have observed gk20a error.(Attached log for reference).

We will keep you posted once we are able to regenerate hang issue.
gpu_error.txt (137.6 KB)
jetson_nano_boot_log_working_condition.txt (81.0 KB)

Hi Wayne,

Jetson nano hangs again on startup. We restarted it multiple times, but hang condition still persists. Please find attached console log for reference.
jetson_nano_hang_issue_log.txt (8.3 KB)


The log says the bootloader is corrupted. You should reflash your board with sdkmanager.

Hi Wayne,

We installed SDK Manager and tried to re-flash jetson nano in recovery mode, but it failed in flashing. We tried multiple times, but failed every-time. Please find attached screenshot of SDK manger log and console log.

Please directly use and see if it can flash your board.

Also, is this your first time flashing jetson devices?

Hi Wayne,

Can you please share exact command to flash boot-loader using

Please check the quick start guide in the document.

Hi Wayne,

We tried to flash using script, but it failed at “sending ebt” steps. Please find attached log for reference.
Jetson Nano Flash loading using script-ebt failed.txt (10.6 KB)


sudo ./ jetson-nano-devkit mmcblk0p1

No -t. Where did you get that? Our document may not teach this command directly.

Also, the most important question so far is actually below one.

Also, is this your first time flashing jetson devices?

And you didn’t reply me yet.

Hi Wayne,

We tested without passing any options to and still it gives same error. Please find attached log for reference.

So far, i have used etcher only to flash OS on jetson device. I am flashing Jetson device using SDK Manager first time.
Jetson Nano Flash loading using script-ebt failed.txt (10.7 KB)

Ok, then you didn’t flash any jetson before. Etcher does not consider a real flash tool.

Is your ubuntu host a VM?

It is VM.

SDKM and both not support VM. Sorry about that.

That was why I asked whether you are new to this or not. Because the most common case for new user is VM.

Hi Wayne,

We installed SDK Manager in ubuntu Host and tried to reflash Jetson nano, but received same error. Please find attached log for reference.
Jetson Nano ebt error in falshing from ubuntu host.txt (10.6 KB)

Do you have other jetson devices that can validate your host?