Flash xavier nx emmc

i have xavier nx devkit without microSD
i want to flash image to internal 16Gb emmc

i tried to do that with SDK manager, but it freeze in 45%
i tried to flash with flash.sh script:
~/nvidia/nvidia_sdk/JetPack_4.4_Linux_JETSON_XAVIER_NX/Linux_for_Tegra$ sudo ./flash.sh jetson-xavier-nx-devkit-emmc mmcblk0p1
but it also freeze (screenshot)

So how can i do that?

Are you using a VM? Or is your host a native Ubuntu 18.04? VMs often suffer from this since they do not handle USB correctly without manual intervention. If not a VM, then are you using the provided micro-B USB cable? Many charger cables have problems with data transfer.

I use a native Ubuntu 16. I can flash with SDK manager, when microSD connected. So i think cable is ok.

Ubuntu 16.04 is a bit old. Is it possible to upgrade your host PC to 18.04?

i have tried with Ubuntu 18 - same problem

I too see the message about “taking longer than expected”. My Ubuntu 18.04 happens to be a dual core Atom laptop with a 10" screen :P

However, if I keep saying that I want to continue (many times), then it eventually completes. My laptop has a slow regular hard drive and only a small amount of RAM, so this is actually expected. Building the image which becomes the rootfs partition is time consuming. Then copy of the many GB of content to the NX over USB would also involve “significant” time.

I suggest using 18.04, and just keep accepting to continue.

i have waited for 12h (by pressing continue more time) - problem not solved
it is staying on Flashing 99% (Flash Jetson OS)

Well, that is definitely too long even for a slow computer. Is it possible to try with a different host PC? Is the USB cable the one supplied by NVIDIA? Very few third party micro-B USB cables have quality for long term data transfer (mostly they are sold cheaply as charger cables, and most of the time work ok for data only at either slow data rates or for short time periods before running into trouble).

I know this thread is old, however I have encountered a situation identical to that of @dinartal. I am using a newer version of Linux for Tegra (4.9.201-tegra), and have attempted to flash the Jetson Xavier NX onboard eMMC with a DevKit however it is freezing (taking forever – over 18 hours). I too am running:

sudo ./flash.sh jetson-xavier-nx-devkit-emmc mmcblk0p1

However, I have tried multiple host computers (both modern and multi-core) running Ubuntu 18.04 LTS on bare metal (non-VM) and have encountered it just freezing. I have also tried multiple microUSB cables, including ones of higher-quality.

  1. Do you suspect it is the cable? If not, what do you think might be causing this?
  2. Can you recommend a cable from Amazon to purchase? Our NX DevKit did not come with a microUSB cable.

Thank you!

You should probably start a new topic, but try this flash first (assuming this is an SD card dev kit):
sudo ./flash.sh jetson-xavier-nx-devkit mmcblk0p1
(note that I did not use “-emmc”)

Note: Dev kits should come with a micro-B USB cable. You can use a “charger”/“OTG” cable from a store, but you’d have to try it to see if it works or not. No way to predict if the quality is high enough, but probably 3 out of 4 “charger” cables have poor data quality.

I think there is NOT EMMC memory on dev kit board with MicroSD slot.
@linuxdev is it true?

1 Like

This is correct. However, there is some QSPI memory (used for boot).

1 Like

Yes! That was exactly the issue, the NX module shipped with the DevKit did not contain an eMMC. We replaced it today with a module we purchased separately and it flashed like a charm!

Thank you both!