Frame Profiler on Ubuntu 16.04

Hello,

When I use the “Frame Profiler” with any application, NSight Graphics successfully launches the application but then does nothing else. The tool’s window is completely empty and the only two buttons that I can press are “Disconnect” and “Terminate”. Is there some configuration step that I am missing?

Relevant info:
Ubuntu 16.04 (4.15.0-66)
RTX 2060
Driver 440.31
CUDA 10.2
NSight Graphics 2019.5.1.0

I am using the “simpleGL” example that comes with CUDA Samples. I have also tried other applications with the same result.

Frame Debugger seems to be working fine in that I can pause and inspect the application (but I haven’t really dug into it).

Thanks!
nsight-graphics-frame-profiler.png

Update on this: I can do “Capture for Live Analysis” as long as I don’t collect hardware metrics. If I do, the tool crashes.
When I do “Profile Frame” in Live Analysis mode, it gives the following error:

Profiling not available on this GPU or
ERR_NVGPUCTRPERM: Failed profiler permission check.

I am running as sudo. I have also followed the instructions on this page and set the driver settings: https://developer.nvidia.com/nvidia-development-tools-solutions-ERR_NVGPUCTRPERM-permission-issue-performance-counters#SolnTag

But since I am running as sudo, those shouldn’t even matter.

I have also tried 2019.6 and gotten the same results.

Hello,

Thank you for your feedback on Nsight Graphics. Our engineer is investigating your issue and we will respond with some feedback after the investigation.

Regards,

Darrell

Hello,

We have a fix for the following issue and I will get back with you on when the fix will show up in a release.

  • When you do “Profile Frame”, it shows the error, ERR_NVGPUCTRPERM.

However, we had some issues trying to reproduce the following issues you had. We tested on Ubuntu 18.04 and 16.04.

  • Nsight Graphics can’t capture after launching the application “simpleGL”
  • Nsight Graphics has host crash with launch “simpleGL” with “Collect Hardware Performance Metrics” enabled

Can we get more details on how you installed the Nvidia driver and the Cuda Toolkit? That may help us to reproduce the issues you saw. Sometimes the installation of the Cuda Toolkit can conflict with the driver.

Apologies for the delay. I had installed both the driver and toolkit using the .run file from the NVIDIA website.

Anyway, I just tried NSight Graphics 2020.1 and the issue seems to have gone away. I think we have all the information we need right now but I’ll let you know if I find something that still isn’t working.

Thank you very much!