OpenGL Application: Profiling not available on this GPU or ERR_NVGPUCTRPERM: Failed profiler permission check.

I currently cannot profile a frame for my 32Bit OpenGL 4.5 application with Nsight Graphics 2019.3.0.0

Capture for Live Analysis works.
I do see correct GPU timings in the Events View and the Scrubber View.
I do see the correct shader sources in the Shader Source View
I do see correct buffer contents (and revisions) in the Resources View

But when I Click “Profile Frame” the Range Profiler View shows no details, only a message:
“Profiling not available on this GPU or ERR_NVGPUCTRPERM: Failed profiler permission check.”

I tried starting Nsight Graphics as administrator, i tried giving access to GPU performance counters via the NVIDIA Control Panel (pretty much what i could find on the internet so far).

Profiling a random DirectX application (e.g. NvFlexDemoReleaseD3D_x64.exe from NVIDIA Flex) seems to work, access to hardware counters and metrics show up after clicking “Profile Frame”.

Is this a known bug or even a known limitation with the OpenGL driver, or do i need to activate instrumentation flags somewhere in my OpenGL initialization?

System Stats:

OS:
Windows 10 Pro, 64Bit, Version 1809

GPU:
GeForce RTX 2080 (Laptop)

Driver:
430.86 DCH

Thanks,
Dominik

Same here with a simple Vulkan program on Win10 1903.

Hi Dominik,

Sorry that you are running into this issue. Unfortunately, our error message here could use some work.

Currently, Range Profiler does not support profiling for OpenGL applications on Turing based GPUs(20 series). We are hoping to add support for openGL profiling on Turing GPUs soon, but as of now, deep profiling with the range profiler won’t be possible.

If you have a pascal card, you could try that, but it sounds like you are on a laptop.

Again, sorry for the inconvenience. We are hoping to close this gap soon!

Thanks,
Seth

Although, your simple Vulkan sample should not have given you the same error. Is it also giving you the ERR_NVGPUCTRPERM error?

Really just as described by the OP. In the Range Profiler View there’s the “Profiling not available on this GPU or ERR_NVGPUCTRPERM: Failed profiler permission check.”
That’s on a Geforce 1060 card. Permission was granted.

Test apps:
https://github.com/jpystynen/vulkantoy
https://github.com/vinjn/shadertoy-dx11

DX does work.

Hi Hoganmeier,

Thanks for the applications. I am unfortunately not able to reproduce the issue.

Here is a screenshot with it working on the latest version of Nsight Graphics (2019.3.1)

I know we recently found a similar issue to this though which will be fixed in our next release at the end of July.

Thanks,
Seth