Frozen bootup screen/login loop for Ubuntu 20.04 LTS with NVIDIA driver 470.182.03


Here are the log files:

The nvidia log file:
nvidia-bug-report.log.gz (201.5 KB)

dmesg output:
dmesg-output.txt (70.7 KB)

Detailed description:

On my Ubuntu 20.04 ( kernel 5.15.0-75-generic ) I get a solid non-blinking cursor during the booting process after installing nvidia 470.182.03 driver:

Things I have tried ( by using ctrl + alt + fx to get into a terminal from the frozen screen ):

  • Edit sudo nano /etc/default/grub to add 'nomodeset to GRUB_CMDLINE_LINUX_DEFAULT [source]:

  • Editing the /lib/udev/rules.d/61-gdm.rules file and commenting lines to prevent Wayland from being disabled. However, I encounter a login loop after doing so [source]

  • Ensuring I have linux headers for the kernel I am using and reinstalling drivers:

  • Stopping and disabling various systemd services as mentioned here

Okay, I have managed to get it working now. Posting steps and details for whoever might come to this thread with a similar problem:

  1. I had initially tried to install the driver using the runfile installer ( 470.x’s ‘.run’ files from nvidia’s downloads page ) which got executed with failures. This probably happened as my linux headers weren’t installed for that kernel at that time and various subsequent changes, modifications etc further messed up configurations related to the driver.

  2. I tried many things found online including installing headers and installing drivers from the Software and Updates utility ( and also tried the run file again ). The driver got installed but I was facing the issue mentioned in the thread ( frozen boot screen/login loop ).

  3. I did a fresh install of Ubuntu 22.04 LTS ( 5.19.0-45-generic ) and then before installing anything else, I ran

sudo apt update
sudo apt upgrade
  • And this time, after reading many posts and going through many threads I tried @generix 's ( big thanks! ) advice on not using runfiles ( mentioned in a reply here ) and using the Software and Updates utility instead to install drivers.
  • I then installed the recommended ( 470 ) driver from there and did a reboot and it all worked as expected.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.