GANverse3D Extension fails to load

Hi,
I am trying to load the GANverse3D extension following tutorial on a Linux machine.

The CREAT app complains about onnxruntime , full log kit_20210916_155733.log (534.0 KB)

ISAAC app complains about extension dependencies. full log kit_20210916_162546.log (281.5 KB)

I would really like to run the GANverse3D so any idea how I can get around please.

Many thanks
TS

same here,. very unpro tools LOL

GANverse3D is still in beta, the dev team is working hard on improving it! We really appreciate you taking the time to report your issues with us!

I informed the development team about this post to help you get some answers.

I, too, cannot load (enable) the GANverse3D (Image2Car) Extension. I have been trying to get it to work since it was made available.

I followed the steps, as another poster mentioned/linked to in a post above, to download the .zip file and import it into the list of Extensions, but when I click to ‘enable’ it, it shows a red exclamation mark symbol in place of the enable/disable switch. It is thus not able to been seen/used within Omniverse.

Looking at the console log, it makes mention of 'ModuleNotFoundError: No module named ‘onnxruntime’…

This is on Windows 10, build 21H1, using the latest Studio Drivers with an RTX 3090 card, and an Intel Core i9 10940X CPU (X299 platform) with 64GB of RAM . The various Omniverse apps, Connectors, Launcher, etc are always updated when new versions become available.

I have re-downloaded the .zip file, and tried various other troubleshooting steps, but it’s always the same result… A red exclamation mark, and the Extension is not enabled.

Thanks in advance for any assistance.

2 Likes

installed version 2021.3.6
GANverse3d extension still not able to load.

Hello @Tsluan, @burnpepper, @Manatoba, & @fsheng21! The development team has a solution cooking for this issue. Right now it is being tested in our QA Department. It should be available for the next release.

3 Likes

Hello @Tsluan, @burnpepper, @Manatoba, & @fsheng21. The last compatible version was Create 2021.3.3. We’re working hard on getting an updated extension that will add compatibility with the latest versions of Create. Thank you so much for your patience and interest in Ganverse3D and Omniverse!

2 Likes

Hello @Tsluan, @burnpepper, @Manatoba, & @fsheng21! Thank you so much for your patience. The updated GANverse3D extension is now available for Create >= 2021.3.4. You can get it directly from the Extension Manager (Window->Extensions), searching for aitoybox and hitting the Update button. (Note that it may take several minutes to download, depending on your connection).

We will be updating the documentations shortly with instructions on how to obtain the extension as a zip file for anyone with a slower connection. Thank you again for your feedback and interest! Please let us know if you encounter any other issues.

2 Likes

Ok, GANverse3D Image2Car is working now. Thank you to the team.

1 Like

@jlafleche Thank you for updating this. It is working for me as well. Good work!

1 Like