Gaze Redirect ERROR: Cannot create a CUDA stream

Hi,
wanted to use Gaze Redirect for pre-recorded videos, but I get the error:

I use a RTX A4500 and the latest CUDA version was just installed (12.0)

Why do I still get the error that a cuda stream canot be created, and that the dynamic library cannot be loaded?

I’m not experienced at all!

1 Like

I have the same problem with RTX 3050. Latest cuda installed, and also nvidia broadcast Version 0.7.2 (beta). I am trying to use v0.8.2.0 maxine ar SDK pack.

“Cannot create a cuda stream: Error loading the dynamic library
ERROR: Initializing Gaze Engine failed.”
GazeRedirect App appear with grey background and suddenly disappear.

This appears to be an error as the system cannot locate the dlls in the “bin” directory. Does the SDK sample run when using the run_local.bat ?

Thank you for your help!

You were right the “bin” directory was missing before. This video also helped me a lot How To Install Eye Contact AI | NVIDIA MAXINE | Gaze Redirect - YouTube

thanks for linking my video happy to help :)

1 Like

I have this error that says my cuda version is insufficient. I installed the cuda toolkit and I don’t know what seems to be the issue here.

having the same issue, I do have the bin folder in there

downloaded from this link:
https://drive.google.com/drive/folders/1EH-oSgPOSV_U3vaGVrB6pvJ42_gM48zw
(there will be 2 zip file, extract both of them, else it will give error for missing files)

changed the run.bat as:

SETLOCAL
SET PATH=%PATH%;…..\samples\external\opencv\bin;…..\bin;
SET NVAR_MODEL_DIR=…..\bin\models
GazeRedirect.exe --offline_mode --split_screen_view=false --in=example.mp4

placed the sample video as example.mp4 in the GazeRedirect folder

works fine with me

I have a: NVIDIA GeForce RTX 3050 Ti Laptop GPU

I have had Nvidia broadcast work on this device that uses the same technology.

I’m experiencing the same error and everything is where it should be:

Cannot create a cuda stream: Error loading the dynamic library
ERROR: Initializing Gaze Engine failed

I’ve followed and downloaded the folder with the bin already included from the video, but keep getting this error. Anyone know why?

https://drive.google.com/drive/folders/14gK4LkJXR5Y4WCUYfqfLCmgKSAl1idoL

Hello! I’ll need some more information about the operating system and the driver version you’re running. I’ll try to assist where possible. This error “Cannot create a cuda stream: Error loading the dynamic library” usually points to a DLL that is not available to the system.

Since a Google drive is not a safe way to distribute our SDKs and I would not support it - I would suggest downloading the Maxine AR SDK directly from the NGC website and giving it a try:

Thanks for the reply. I’ll go ahead and download that and try that.

I’m running windows 11. What other specs do you need?

That is it. Give the SDK from NGC a try, you should find it easy to use!

I got it to work. Thanks! now it doesn’t seem to include the audio on the new rendered video? It also includes a little water mark in the upper left corner and the frame rate or timing is off. Is there way to manage the output settings to keep everything aligned with the original?

Gaze redirection files do not include audio output. There are cli options available to the user… although they’re not provided in the README for one reason or another. My suggestion is to edit the sample batch file and add another line containing the base command with the only parameter being -h. Each time you run the command the help output will be displayed in your terminal. I have found that the watermark is there as well. I normally scale up my video during editing to crop it out.

The SDK sample is a demo of the tech. It wasn’t really intended for post-production uses but it most definitely does work for that so long as you’re okay with a bit of editing. I understand where you’re coming from as I produce Maxine demo videos and have to do the same things to get the output I want.

Thank you. I’ve observed that it’s rendering at 23 frames per second instead of the expected 24, which seems to be the reason for the audio desynchronization. Attempting to align the audio and video durations using time mapping in post-production becomes less effective as the length of the video increases. Is there any method to ensure matching frame rates?

To follow up, the SDK samples include the source. If you would like to add functionality or further polish them for post production you can. The .cpp files are what you are looking for!

I see a bunch of references to FPS or frame rate in the .cpp files (there seems to be two .cpp files), but I wouldn’t know what to tweak to make the frame rate match the original video file. I would think by default it would just take the current frame rate and render it that way.