GeForce 740M / Asus X550L / CODE 43 AFTER WINDOWS 10 UPDATE

well it’s a two way street. Either their Drivers aren’t compatible with our computers or Windows dropped the ball somewhere. I’m Trying to go back to windows 7 with no success whatsoever. My Pc is reduced to a writing station. Not, freaking, cool.

I’m having the same issue. I’ll give it a week before I get a new mac desktop since this is just ridiculous windows.

Bump Still not resolved

I found the issue BIOS 100%out of date, got system information app and check out ur bios date. If older then website vesion update it.

Hi, I have the same story.
Notebook ASUS K551LB NVIDIA GeForce 740M Windows 10 latest BIOS from asus website
It happens every time when I’m alt-tabbing from a game and then get the BSOD, then the code 43 comes back again. In my case, I enter to BIOS setup and just exit it with “save” option, and my video driver works again. But it does not help me each time, some times it requires several tries. Probably there is a problem with video card initializing in Windows 10

I have the same annoying issue. I’m on notebook ASUS UX302LG NVIDIA GeForce GT 730M.

The card was working fine the first 2 days when I upgraded from Windows 8.1 to 10. All of a sudden I get a BSOD stating VIDEO_DXGKRNL_FATAL_ERROR while windows was shutting down. After which, the notebook rebooted automatically into BIOS. I tried exiting the BIOS but the notebook just kept booting into BIOS. I manually powered off by holding the power button and powered it back on and it started up normally with the Code 43 appearing ever since the BSOD.

Tried updating the BIOS ANG_60 recommended and it works! Thanks a bunch!

Hopefully it stays that way though.

If anyone is still having this issue, and installing the driver via Windows Update doesnt resolve the code 43, PM me please.

Which driver via Windows Update? Win10 says I have no new updates, but I’m certainly stuck on Code43.

I have the same problem. However,it was working perfectly until i tried to upgrade windows 10 geforce driver. I thought it needed to be upgraded but apparently i was wrong. This problem must be fixed as soon as possible. If anyone can find a solution, please let me know.

Same issue with my gtx 745m. It has not been working for an entire month. Neither the recent update nor the update before that fixed it. Geforce experience doesn’t even work and every solution I’ve found on this error either doesn’t work or is too old to be of any use.

Guy I solved all problem with the latest bios version (v. 208 for my ASUS)!!!

Could you explain to us in detail what you did that way anyone else who has this same issue can follow your steps and potentially fix their problem? That and quite honestly I have no idea what bios is or how to implement it into my laptop :/

  1. check your BIOS version https://www.asus.com/support/FAQ/1008325/
  2. check the last version on productor’s website
  3. if necessary update BIOS http://www.asus.com/en/support/FAQ/1008276/

It worked for me

U.

I’ve had this issue a few times over the past year, but I have managed to get it working again after hours of Uninstall/Install cycles and the last time it happened I upgraded the BIOS.

I was reluctant to upgrade to Windows 10, but after the upgrade the video card worked fine. Upgraded August 9th, the driver Code 43’d me yesterday afternoon (August 25th) and none of the old tricks worked to revive the driver.

ASUS Q550L
GeForce 745M

So after a few more hours of trying and searching the web for solutions I found another that worked for me.

Deleted “numbered” drvier folders in C:\Windows\NVIDIA\Display Drivers
Uninstalled NVIDIA products via Windows Unistaller, making sure to uninstall the Drivers package LAST.

Installed base ASUS driver version 918133285 from ASUS website
Installed 340.52 successfully, after. Just a straight upgrade, clean install not selected.

In the past I’ve tried to install 344.48 but it failed. I’m leery to install anything higher than 340.52, even though I’ve read others’ success with higher released driver packages.

It would be great to know why this happens, and why no solution ever seems to work more than once.

The BIOS upgrade fix does not seem to be a permanent fix to the Code 43 issue. I upgraded my BIOS to version 210 on the Asus website on 20/08/2015. I’m on Asus UX302LG.

This morning I got the same BSOD while shutting down with the same message VIDEO_DXGKRNL_FATAL_ERROR that I posted a few posts back. And now I can’t upgrade the BIOS any further as I am already on the latest version.

This does not seem to be a driver issue as the drivers I’ve tried for Windows 10 seem to work at least for a while until the BSOD. Somehow after the BSOD the card does not seem to be able to initialize at boot. We need answers and a fix.

Notebook Asus X550LB-XX053D, CPU Intel® Core™ i7-4500U 1.80GHz, Haswell, 8GB, 750GB, nVidia GeForce GT 740M 2GB Optimus. BIOS 403
Worked fine on Win 8.1. After upgrade to Win 10 I cannot use GeForce GT 740M video card because of code error 43. I have tried a lot of driver versions but none of them solved the issue. Everytime I used DDU to uninstall the previous driver, but the problem persists.

Asus support encoureged me to roll back to Win 8.1, NVIDIA Live Support suggested me to disable on-board video card (not possible - not available in BIOS, if disable in Device Manager problem persits), Microsoft didn’t answer till now via e-mail and I couldn’t reach them by phone.

Does anyone have any ideea how to solve this issue?
If any further info is required I can provide.

Thanks in advance!

Cheers,
Daniel

I managed to flash my BIOS again using the same version and the Code 43 is gone.

For those on ASUS,

Please use the following guide to update your BIOS (if you wish to update to the latest version):

  1. Follow the instructions in the following link: http://www.asus.com/support/FAQ/1008276/
  2. Winflash will not allow you to flash if you are trying to downgrade or use the same BIOS version as your existing one (the flash button will be greyed out).

If you wish to flash the same BIOS version as your existing one follow the instructions below:

  1. Follow the instructions to download BIOS and Winflash using the same link above.
  2. Launch “Command Prompt” by searching using the search function beside the start menu.
  3. Enter “cd C:\Program Files (x86)\ASUS\WinFlash” without the “” and hit enter
  4. Enter “Winflash /nodate” without the “” and hit enter.
  5. Winflash will open.
  6. Select the respective BIOS version you downloaded (The flash button should not be greyed out).
  7. Proceed to flash.

I have only tried flashing the same version of BIOS as my existing one and it works. I do not recommend downgrading your BIOS version as I personally have not tried and do not know what will happen.

This seems to be the only temporary fix now whenever the Code 43 appears for me.

Cheers,
Danny

I updated my bios but not fix to the Code 43 issue. Mine is X550LB too

So, even if it sounds funny removing and reinstalling the battery solved my problem!!! I’ve read about this “trick” but I couldn’t believe it :) but, my notebook has been frozen the other day and there was nothing I could do. So, I have removed the battery and after a very long boot (at 3-4 minutes) a random “right click” caught my attention because I have seen NVidia Control Panel!!!

Actually, I wouldn’t bet on removing and reinstalling the battery, but definitely deserves a try!

I do not know how to figure out which driver version is installed … might be interesting for some people. I made a print screen but I have no upload button!

From the Device Manager I extracted:

Driver Provider: NVIDIA
Driver Date: 13.07.2015
Driver Version: 10.18.13.5354
Digital Signer: Microsoft Windows Hardware Compatibility Publisher

Hope all these can help,

Cheers,
Daniel

NVIDIA Graphics Driver 353.54
NVIDIA Update 10.4.0