geforce 7500 LE Driver Problem

Im using Ubuntu 9.04 and i have a nvidia geforce 7500le, everytime i use linux to install the driver which is NVIDIA Accelerated Graphics driver (version 180), it doesnt work. i restart my computer and i makes me run in Low graphics mode because theres a problem it says the card failed, unable to initialize the card. So i went back and went to an older version of the driver which is (version 173) and it did the same thing failed once again. I tried this multiple times it didnt seem to work. I also tried to install the driver myself using the guide here http://forums.nvidia.com/index.php?showtopic=99513 everything happened as he said i did everything right but i still got the same results, my gfx card keeps failing i dont understand.
If u guys can please help me figure this out. and give me step by step instructions because im a newbie and thats why im in this forum. thx alot i hope u guys can help
~Kulocka

Try something like:

dmesg | grep -i nvidia

and post result…

(dmesg print the kernel ring buffer, grep print lines matching a pattern)

Cheers,

luca

This is what i got when i typed that in, im not sure wut u meant by the other part.

[codebox]kulocka@kulocka:~$ dmesg | grep -i nvidia

[ 0.000000] Nvidia board detected. Ignoring ACPI timer override.

[ 14.306421] nvidia: module license ‘NVIDIA’ taints kernel.

[ 14.565684] nvidia 0000:02:00.0: PCI INT A -> Link[APC5] -> GSI 16 (level, low) -> IRQ 16

[ 14.565691] nvidia 0000:02:00.0: setting latency timer to 64

[ 14.567102] NVRM: loading NVIDIA UNIX x86 Kernel Module 185.18.36 Fri Aug 14 17:18:04 PDT 2009

[/codebox]

Your kernel is trying loading 185.18.36 module that’s, I think, Jaunty proposed driver… If you are installing drivers other than Ubuntu proposed (the ones coming from the repository), try to edit /etc/default/linux-restricted-modules-common configuration file and disable the NVIDIA linux-restricted kernel modules (nvidia, nvidia_legacy), in this way:

sudo nano /etc/default/linux-restricted-modules-common

and add following line:

DISABLED_MODULES="nv nvidia_new"

Cheers,

luca

yea thanks for the tip but it didnt work…instead i got more problems on the start up. it gave me a huge list of problems and i have them all here now.

codebox Failed to load /usr/lib/xorg/modules/extensions/libglx.so

(EE) Failed to load module “GLX” (Loader failed,7)

(EE)NVIDIA(0): Failed to initialize the GLX Module; Please check in your X

(EE)NVIDIA(0):Log file that the GLX module has been loaded in your X

(EE)NVIDIA(0): Server and that the module is the NVIDIA GLX Module. If

(EE)NVIDIA(0):you continue to encounter problems, please try

(EE)NVIDIA(0):reinstalling the NVIDIA Driver

(EE)NVIDIA(0):Failed to initialice the NVIDIA Graphics Device PCI:2:0:0

(EE)NVIDIA(0): Please see the common problems section in the readme fo

(EE)NVIDIA(0): Additional Information

(EE)NVIDIA(0): Failed to initialize the Nvidia Graphics Device!

(EE)Screen(s) found, but non have a usable configuration[/codebox]

this was after trying that method… i had about half this b4 i tried the other method

hope this helps you help me

But good thing is after i did that it says my gfx card is now active…but it still doesnt do anyhting…and i keep getting errors in the begining

I think there are two options that could work:

1 - try to reinstall your drivers (being sure you are downloading the correct one; for example 32 bit driver for a 32 bit system), typing:

sudo sh <diver_name>

			   sudo nvidia-xconfig

2 - try to use your own distro modules (with legacy support maybe is the better choice). In this case comment the line:

#DISABLED_MODULES="nv nvidia_new"

Please also post X log file…

Cheers,

luca

If 1 doesn’t work maybe you can type:

./....run --x-module-path=/usr/lib/xorg/modules/

Let me know,

luca

srry im a noob how do i get the x log file? and the other attempts didnt work i tried all of it just now…i got an error but not as big as b4…thanks for helping me tho luca, hopefully we can fix my comp.

less /var/log/Xorg.0.log